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Before You Begin 

Thank you for purchasing ACD/ChemSketch.  We have endeavored to produce the easiest to 
use, most powerful program for drawing chemical structures, reactions, schematic diagrams, and 
designing other chemistry-related reports and presentations. 

Freeware Version 

From April 1999 onward, Advanced Chemistry Development, Inc. (ACD/Labs) has been making 
ACD/ChemSketch available as a freeware at our Web site: 

http://www.acdlabs.com/resources/freeware/chemsketch/ 

Important ACD/ChemSketch freeware should be installed in its own separate folder.  
This folder can contain other ACD/Labs freeware concurrently available but it 
should not contain any purchased ACD/Labs software. 

All of the limitations on the freeware and also the Frequently Asked Questions (FAQs) can be 
found on our Web site at: 

http://www.acdlabs.com/resources/knowledgebase/faqs/chemsketch_freeware.php. 

About This Tutorial 

Completion of this tutorial should give you the tools needed to get started with ACD/ChemSketch, 
it is designed for either online use or to be printed and used as a “hard copy” version. 

The screen shots shown throughout this tutorial have been taken with a relatively small window 
size. 

The colors and other properties of the window elements described throughout this tutorial 
correspond to the Windows Classic Theme (with dismissed gradients) of the operating system’s 
Display Properties. 

This tutorial is provided in electronic form, readable with Adobe software.  If you cannot locate an 
index topic you need please do a text string search for the relevant word or phrase, or related 
words. 
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Advanced Understanding 

This tutorial is intended to be a part of the technical documentation for ACD/Labs software.  To 
study ACD/Labs products gradually, we recommend the following order of working through the 
technical documentation (the corresponding documents are located in the ACD/Labs 
documentation folder, \\DOCS): 
1. Reference manual (CHEMSK_R.PDF) and tutorial (the current document) for 

ACD/ChemSketch. 
2. User’s Guides for ACD/Dictionary (DICT.PDF) and ACD/3D Viewer (3D.PDF) that familiarizes 

you with features of drawing and looking up structures. 

In addition, it is advisable to have knowledge of the following ACD/Labs products (the 
corresponding documents are located in the ACD/Labs documentation folder, \\DOCS):  
1. ACD/I-Lab (ILAB.PDF)—the Internet-based service that allows you to get instant access to 

chemical databases and property predictions programs (can be downloaded from 
http://www.acdlabs.com for free). 

2. ACD/ChemBasic (CHEMBAS.PDF)—the special programming language that enables the user 
to customize ACD/Labs software (can be downloaded from http://www.acdlabs.com for free). 

3. ACD/Name to Structure (NAMESTR.PDF)—generates a molecular structure for almost any 
chemical name.  ACD/Name to Structure processes the majority of the names of general 
organic compounds and many natural product derivatives according to IUPAC 
Recommendations on Organic, Biochemical, and Inorganic Nomenclature (should be 
purchased in addition to ACD/ChemSketch). 

Mouse Conventions 

You may perform several actions during your work with this software; the following specific words 
are used to describe them: 

• Point to means move the mouse pointer  to an item. 

• Click means point to an item, and quickly press and release the left mouse button. 
• Right-click means point to an item, and quickly press and release the right mouse button. 
• Double-click means point to an item, and quickly press and release the left mouse button 

twice. 
• Drag means point to an item, and press and hold down the left mouse button while you 

move the item. 
• Select means highlight or make an interface element active either by clicking it or dragging 

over it (other actions are possible if specified in documentation).  If used in "select the 
check box", it means that the check box should be marked with a tick (as opposed to "clear 
the check box" when the check box should be cleared, without a mark). 
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For More Information… 

To see the latest in ACD/Labs software and services, please visit our Web site at  
http://www.acdlabs.com/ 

Our Web site is being accessed at the rate of tens of thousands of “hits” per day.  There’s a 
reason for this: much is offered through our Web site.  We offer free ACD/ChemSketch, an 
ACD/LogP Freeware Add-on for ChemSketch, a free ISIS 3D Add-in, free ChemDraw extensions, 
and a free 2-week demo key for “Interactive Laboratory” sessions where you can run test 
calculations using Java applets without purchasing software.  There are TechSmith Camtasia-
based movies which show the operation of many of our software packages (especially 
ChemSketch).  The movies can be run from the ACD/Labs software folder, \\MOVIES. 

We are constantly updating the information on our Web site.  The Web site will tell you at which 
scientific conferences you can visit the ACD/Labs booth.  You can browse the Frequently Asked 
Questions page or drop in and “chat” on our newsgroup, which can also be reached via our Web 
site. 

If you would like to stay informed of the latest developments in chemical software at ACD/Labs, 
please be sure to sign up for e-mail broadcasts at our Web page: 

http://www.acdlabs.com/newsletters/ 

How to Contact Us 

We are accessible through our Web site, phone, fax, and regular mail, but by far the most popular 
way to contact us is via electronic mail.  Questions on pricing, sales, availability, and general 
issues should be directed to: 

info@acdlabs.com 
Technical and scientific support issues should be addressed by visiting: 

http://www.acdlabs.com/support 

Please tell us the name of the software purchaser; the product name, version number, build 
number, and license ID of the product you are contacting us about (from the Help menu, choose 
About to find this information); as well as a description of the problem you are having.  If 
applicable, please tell us the name of the distributor from whom you purchased the software. 

Online Updates 

Updates of our Desktop and Enterprise products are made throughout the year.  These 
intermediate releases (bringing the actual version number of a program, for example, from N.00 
to N.01) often contain new functionality along with additional bug fixes and support for new file 
formats.  To check if there is a new update available and to have this sent to you, please contact 
your local agent or our Technical Support Department.  Before calling, we recommend that you 
have ready the name of the software purchaser, the product name, version number, build 
number, and license ID of the product you are contacting us about.  All Desktop ACD/Labs 
software contains the capability to have software updates delivered online.  You will need the 
registration numbers of the software and an Internet connection from the same computer on 
which the software is installed.  For more information, refer to the ACD/Updater User’s Guide 
located in the ACD/Labs documentation folder, \\DOCS\UP_CLNT.PDF. 
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1. Basics of ACD/ChemSketch 

1.1 Objectives 

This chapter will familiarize you with: 

• Starting ChemSketch; 
• Setting and changing file associations; 
• Setting default directories; and 
• Quitting the program. 

Information about minimum system requirements as well as installation instructions are provided 
in the Quick Installation Guide booklet which is included in every shipment of ACD/Labs software. 

1.2 Starting ACD/ChemSketch 

Once ACD/ChemSketch has been installed on your computer, use one of the following ways to 
start it: 

• On the Start menu, point to (All) Programs, after that to ACDLABS 2012.0, and then 
choose ChemSketch; or 

file; or 
• In the folder where the ACD/Labs software is installed (by default, this is \\ACD2012), 

double-click the CHEMSK.EXE program 
• If you have other ACD/Labs programs running, from the ACD/Labs menu of the program, 

choose ChemSketch. 

Note If you have created a shortcut to ACD/ChemSketch on the Windows desktop, click 
it to run the program. 

As a result, you should see an ACD/ChemSketch splash screen.  If this is the freeware version, 
you will see the ACD/Labs Products screen.  Click OK to close it.  If you wish to suppress this 
dialog box for the subsequent startups, from the Help menu, choose ACD/Labs Products, and 
clear the Show this Screen at Startup check box. 
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1.3 Setting File Associations 

If you run ACD/ChemSketch for the first time, the File Associations dialog box appears: 

 
It contains a selectable list of file extensions and file types, e.g. CS ChemDraw (*.CDX), MDL 
RXNfiles (*.RXN), ISIS/Sketch (*.SKC) which you may want to open automatically with ACD/Labs 
software from now on.  If so, click the check boxes of the file formats you want to add, and then 
click Yes. 

If you do not want ACD/ChemSketch to open files with the listed extension automatically, or are 
not sure, leave the check boxes blank, and click No. 

Then you will see a Tip of the Day box, which you can close after reading. 

1.3.1 Changing File Associations 

If you have not selected all formats, the default file association can be viewed or changed at any 
time; from the File menu, choose File Associations. 

Note If you choose File Associations under Windows NT while you are not entitled to 
change file associations in the system, a warning message appears.  Contact your 
system administrator to resolve the matter. 

If all formats are selected, you receive a message, “all supported file types are already 
associated with the current application.”  In this case, you can change the file associations 
through Windows Explorer. 
1. Open Windows Explorer, and select a file with the extension for which you want to create the 

association. 
2. Hold down SHIFT and right-click the file name.  From the shortcut menu, choose Open With.  

Note that in some Windows operating systems (e.g., Windows XP) you do not have to press 
SHIFT to get Open With on the shortcut menu. 
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3. Set the application that should be used to open the file and select the Always use this 
program check box. 

4. Click OK and close Windows Explorer. 

1.4 Changing Default Directories 

If you are running a single-user (stand-alone) copy of ACD/ChemSketch, the default directory 
settings are likely appropriate. 

If you have a network copy, it is advisable to change the default directory settings in the 
ACD/Labs software so that the default drive for saving work-in-progress is the user’s local hard 
drive, not the remote server.  After creating local access for either limited or unlimited number of 
seats, then at each local installation: 
1. In the ChemSketch window, from the Options menu, choose Preferences. 
2. In the dialog box that appears (note that the General tab is active), under Directories, in the 

Default box, specify the directory that will be opened every time you open the Import, Open, 
Save, or Export dialog boxes in the ChemSketch window: 

 
Note In the Private box, you can set the directory for recording the configuration of 

ACD/ChemSketch (TEMPLATE.CFG and QRSTYLES.STL files). 
3. Click OK. 

1.5 Installing Add-Ons 

Starting from version 8.0, ACD/Labs applications support add-ons—small programs (with 
.ADDON extension) written to extend the features of the main application.  Each add-on contains 
a set of commands to be applied either to the current record or to the whole database (so called, 
batch commands).  As soon as the add-on is installed, its commands can be placed either on the 
toolbar as buttons or on the main menu as commands of the Add-on submenu (Database and/or 
Record menu), or both. 

To install an add-on in ACD/ChemSketch, follow the steps below. 
1. From the Options menu, choose Add-on Organizer. 
2. Click Add and, in the Open dialog box that appears, find the .ADDON file. Click Open to add 

it to the list. 
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3. To customize some of the add-on options, select it in the list, and click Edit: 

 
4. In the Available Commands box, select the commands to be accessible from the 

ACD/ChemSketch interface. 
5. In the Insert In area, choose where the add-on commands should be added: as commands to 

the Add-Ons menu and/or as buttons to the General toolbar (if it was implemented by the 
add-on author), and click OK. 

6. Click OK in the Add-on Organizer dialog box, and ensure that the menus and/or buttons are 
added to the interface. 

1.6 Quitting ACD/ChemSketch 

The ChemSketch window can be opened when you start either CHEMSK.EXE or almost any of 
the ACD/Labs applications (except for ACD/Labs Batch programs).  So, when you quit an 
ACD/Labs application, ACD/ChemSketch will be quitted correspondingly. 

You can quit ACD/Labs programs in any of the following ways: 
• On the title bar of any window, click Close ; 
• Press either ALT+X or ALT+F4—depending on a specific ACD/Labs application; 
• From the File menu, choose Exit—these three ways will close only the specific ACD/Labs 

application to which ACD/ChemSketch serves as a drawing module (or ACD/ChemSketch 
itself in case CHEMSK.EXE has been run on its own account); or 

• From the ACD/Labs menu, choose Exit All—this command will attempt to close all 
ACD/Labs programs that are currently open, one by one. 

You will be prompted to save your work in the appropriate file formats depending on the window 
you are closing. 

Note To continue with this tutorial, do not quit ACD/ChemSketch. 
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2. Drawing Simple Structures 

2.1 Objectives 

This chapter considers the basics of structure drawing, which occurs only in Structure Mode.  The 
objective of this chapter is to give you an overview of the chemical drawing features of 
ACD/ChemSketch.  From this chapter, you will learn how to: 

• Draw various atoms, bonds, as well as labels and polymers; 
• Flip a drawn molecular structure; 
• Select, rotate, and resize drawn structures; 
• Output the structure to a file, document, or printer; and 
• Clean the screen. 

2.2 Drawing Atoms, Bonds, and Labels 

Drawing chemical bonds and atoms is the basic activity in ACD/ChemSketch.  Before you start 
drawing, make sure that you are in the Structure mode which is applicable for all of the actions 
described in the sections that follow: 

• On the General toolbar, click Structure . 

2.2.1 Using the Draw Normal Tool 

The Draw Normal tool  is the default tool when the program is started.  In this mode, you can 
easily draw normal or branched chains and replace the drawn atoms with other atoms from the 
Periodic Table of Elements. 

1. Make sure that the Draw Normal tool  is enabled on the Structure toolbar and that the 
Carbon button  is selected on the Atoms toolbar. 

2. Click in an empty space to draw methane CH4. 
3. Point to CH4 to select it (you will see a rectangle around the methane formula), and then click 

it to add a methyl group to it while creating ethane CH3—CH3. 
4. Click twice the same carbon to draw 2-methylpropane: 

CH3

CH3

CH3 
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5. On the Structure toolbar, click Set Bond Vertically , and click the lower bond of the 
structure to rotate it to this orientation: 

CH3 CH3

CH3

 

6. On the Structure toolbar, click Draw Normal . 
7. Click the right-most carbon atom to draw 2-methylbutane: 

CH3

CH3

CH3 

8. Repeat the above step to draw the following homologous structures: 
CH3

CH3

CH3

, 
CH3

CH3

CH3, 
CH3

CH3

CH3

, 
CH3

CH3

CH3

. 

2.2.2 Drawing Double and Triple Bonds 

Now we are going to draw double and triple bonds: 
1. On the 2-methylnonane structure, point to the last drawn bond (you will see a rectangle 

around the bond), and then click it to make a double bond: 
CH3 CH2

CH3  
2. Click there again to make a triple bond: 

CH3 CH

CH3  

2.2.3 Cancelling Actions 

Another important operation is how to “rescue” yourself from a change that, in retrospect, you 
wish you had not made. 

1. Click Undo .  This will cancel the last action performed and reset the workspace to exactly 
what it was before your last change. 

Note As soon as Undo is executed, the Redo button (beside it) also becomes active. 

2. Click Undo  one more time to return to the 2-methylnonane structure: 
CH3

CH3

CH3

 
Note The Undo command can be repeated up to 50 times.  When you begin to draw 

more complex structures or graphical objects, we recommend that you develop a 
habit of saving your work to a file after making several changes. 

ACD/ChemSketch Tutorial 6 



Drawing Simple Structures 

2.2.4 Deleting Individual Atoms 

You can remove the superfluous atoms from the drawn structure: 

1. On the General toolbar, click Delete . 
2. With the Delete tool active, click the last but one carbon atom of the main chain as shown on 

the picture: 

 
The structure now looks like this: 

CH3

CH3

CH3

 
Note that the whole ethyl group is removed from the 2-methylnonane structure. 

Note Such a simultaneous deletion of terminal group is actual for the CH3, SiH3, NO2, 
etc. groups with non explicitly drawn substituent atoms. 

3. Now, click Undo  to reverse the changes. 
4. Holding down CTRL, click the same carbon atom again: 

CH3

CH3

CH3 CH4

 
As you can see, the last but one atom is removed while the terminal atom of the main chain 
attached to the deleted one is now retained on the page. 

5. Click Undo  to reverse the changes and return to the 2-methylnonane structure. 

2.2.5 Polymers 

ACD/ChemSketch allows you to draw polymeric structures: 

1. On the Structure toolbar, click Polymers  to display the Polymer panel, and then change 
the settings as shown: 
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2. Select two areas to be turned into different monomeric units of a polymer as shown below 
either by clicking starting and ending bonds or by dragging over the required parts of the 
structure.  As soon as the area is selected, the polymer appears in the workspace: 

CH3

CH3

CH3

n n
 

Tip When drawing the second monomeric unit, first point to the bond (not to the bracket) 
and click. 

Right cursor position: . 

Wrong cursor position:  
3. With the second monomer unit selected, in the Index box of the Polymer panel, enter 

different unit’s index, e.g., m, and then click Apply.  The structure now looks as follows: 

 
4. Leave the Polymer Drawing mode by closing this panel. 

5. On the Structure toolbar, click Select/Move , and then select and move adjacent brackets 
of the monomeric units apart from each other: 

 

2.2.6 Pseudo Atoms 

To create open-ended polymers and bent bonds, follow the steps: 

1. On the Atoms toolbar, click the lower right triangle of the Radical Label button , and then, 

from the Radical Labels menu, choose Pseudo Atom . 
2. Click terminal atoms of the structure to replace them with blank atoms and get an open-ended 

polymer structure: 
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2.2.7 Changing the Atom 

To replace an atom with a new element whose button is not displayed on the Atoms toolbar, 
follow the steps: 

1. Click Undo  several times until you return to the 2-methylnonane structure, or draw it 
anew: 

CH3

CH3

CH3

 

2. On the Atoms toolbar, click Periodic Table  to display the Periodic Table of Elements 
dialog box: 

 

3. In the Periodic Table of Elements, click Fluorine , and then click OK.  Note that Fluorine 

button now appears pressed in  on the Atoms toolbar. 
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4. Click the leftmost carbon atom to replace it with a fluorine one: 
F

CH3

CH3

 
Note When you select user-defined elements from the Periodic Table of Elements, the 

corresponding buttons are automatically added to the Atoms toolbar.  To remove 
these buttons from the Atoms toolbar, double-click the Atoms toolbar and in the 
message box that appears, click Yes.  This will remove all user-defined element 
buttons except the default ones. 

2.2.8 Using the Draw Continuous Tool 

This mode is very convenient for “sprouting” new atoms from a selected atom. 

Note When the mode is active, bonds can only be drawn from the highlighted atom. 

1. On the Structure toolbar, click Draw Continuous .  Alternatively, you can press the right 
mouse button to switch to this drawing mode. 

2. Ensure that the Fluorine button  is still selected on the Atoms toolbar. 
3. Click the rightmost carbon atom in the drawn structure to highlight it: 

 
4. Click again to sprout fluorine from the selected carbon atom. 
5. Repeat Steps 3-4 for the same carbon atom again to sprout up the second fluorine atom: 

F

CH3

F

F

 

2.2.9 Drawing Bond Between Two Atoms 

When either Draw Normal  or Draw Continuous  drawing tool is selected, dragging 
from one atom to another draws a single bond between them: 

• With one of the drawing tools active, point to one of the terminal carbons and drag to 
another terminal carbon to draw the following structure: 

F
F

F

 
Note If you drag to or from an empty space, a new atom is inserted at the beginning or 

the end of the drawn bond instead. 
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2.2.10  “Cleaning” Structure 

To standardize all the bond lengths and angles in the drawn structure (“clean” the structure), 
follow the steps: 
1. From the Options menu, choose Preferences, and then, on the Clean tab of the 

Preferences dialog box that appears, select the Method 2 check box as shown in the picture: 

 
2. Click OK to close the dialog box. 

3. On the Structure toolbar, click Clean Structure : 

F
F

F

 
Note The Clean command not only standardizes all bond lengths and angles to make 

the structure look nice—it makes the drawn structures closer to being chemically 
correct.  For acyclic fragments, for example, it places the bonds near the sp2 
carbons at 120o angles and the bonds near the sp carbon at 180o (linear).  If you 
draw geometrical and stereoisomers, the Clean command standardizes their bond 
lengths and angles while retaining all of their structural significance. 

4. On the Structure toolbar, click Set Bond Vertically , and click the carbon-fluorine bond of 
the structure to rotate it as follows: 

F

F
F
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2.2.11 Editing Atom Labels 

The Edit Atom Label  tool allows you to substitute terminal atoms with shorthand 
abbreviations. 

Using the structure cleaned in the previous section, follow the steps below: 

1. On the Atoms toolbar, click Edit Atom Label , and then click the lowermost fluorine atom 
on the drawn structure. 

2. In the Edit Label dialog box that appears, type (CH2)3Ph, and click Insert .  
Note that the label is inserted in the desired position and the indexes are automatically 
subscripted: 

F

F
(CH2)3Ph

 

3. Click Change Position , and then click the label to invert it: 
F

F
Ph(H2C)3

 

Tip If you hold down SHIFT and click the label with the Change Position  tool active, 
the connection point of the label will be changed. 

4. With the Edit Atom Label  tool active, click the resulted shorthand abbreviation to open 

the Edit Label dialog box again.  Then click Expand  to obtain the following 
structure: 

F

F

 
Important Only group abbreviations that substitute terminal atoms as atom labels can be 

expanded by using the Expand  tool. 
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2.2.12 Rotating Structural Fragments 

The expanded 3-phenylpropyl label of the drawn structure looks not smooth enough, so we will 
try to improve its appearance by sequential using of drawing tools of ACD/ChemSketch. 

1. On the Structure toolbar, click Lasso On/Off  to switch to the Lasso selection mode. 

Note There are two selection modes in ACD/ChemSketch: the first mode ( ) selects 

objects with the rectangular selection box, while the second mode ( ) selects 
objects with the lasso selector line.  The latter one, the lasso, allows you to select 
objects in a more specific and precise manner. 

2. Drag over the structure to select the following fragment: 

 

3. On the Structure toolbar, click Set Bond Vertically , and then click the following bond in 
benzene to rotate the entire fragment: 

 

4. On the Structure toolbar, click Select/Move , and then move the selected fragment to the 
appropriate position: 

 

ACD/ChemSketch Tutorial 13 



Drawing Simple Structures 

5. Click outside the selection to cancel it, and then drag up the fluorine atom of the fragment as 
follows: 

 

2.2.13 Drawing Chains 

Using the Draw Chains  tool, you can easily draw chains of any length by click-and-drag 
method. 

1. On the Structure toolbar, click Draw Chains , and point to the atom indicated by the 
arrow: 

F

F

 
2. Hold down SHIFT and drag left to create a carbon chain and note that the carbon counter (C 

#) located beside the mouse arrow changes with each carbon added (when dragging forth) or 
removed (when dragging back). 

Tip The dragging draws a chain where the bonds are set at an angle of 120° to each 
other.  However, holding down CTRL while dragging produces a chain where the 
bonds are set at an angle of 180° to each other. 

3. Continue the dragging until the counter reaches C 8, then release the mouse button to finish 
the chain: 

F

F
CH3

 

4. With the Draw Chains  tool still active, on the Atoms toolbar, click Fluorine , and then 
click the leftmost methyl group three times to sprout three fluorine atoms: 
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5. On the Structure toolbar, click Select/Move , then select these three fluorine atoms’ 

bonds, and click Clean Structure .  The resulted structure of 1,3-difluoro-1-(3-
phenylpropyl)-5-(8,8,8-trifluorooctyl)cyclononane becomes as follows: 

F

F

F
F

F

 
Note The CHAPTER2.SK2 file (Page 1/2) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons:    

, , and  on the Status bar. 

2.3 Cleaning the Screen 

If you want to clean the screen in order to draw your structures from scratch, use one of the 
following ways: 

To insert a new blank ACD/ChemSketch document 

• On the General toolbar, click New Document ; or 

• From the File menu, choose New. 

To insert a new blank page within current ACD/ChemSketch document 

• On the General toolbar, click New Page . 

To clean up an active page within current ACD/ChemSketch document 
• From the Edit menu, choose Select All, and then, from the Edit menu, choose Delete; or 
• Press CTRL+A to select all the objects on the page, and then press DELETE; or 

• On the General toolbar, click Delete , click an empty space away from the drawn 
structures to select all of them, and then click the selection. 

Prior to perform the next actions, clean the screen by inserting second page within current 
ACD/ChemSketch document. 
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2.4 Using ACD/Dictionary 

For Commercial Version only 

ACD/Dictionary allows you to find a molecular structure for common drug names. 

1. On the References toolbar, click ACD/Dictionary  to display the ACD/Dictionary dialog 
box: 

 
2. Click the program icon ( ) on the left side of the title bar to view the commands controlling 

the dialog box, and ensure that the Copy Structure with Name command is not selected. 
3. In the Quick Search box, type caffeine.  As you type, the list scrolls, displaying the 

corresponding names.  As soon as the required name is visible in the list, click it to select.  
The corresponding structure is displayed in the preview area to the right. 

4. Click OK to place the selected compound onto the workspace.  Note that the structure’s 
outline is attached to the mouse pointer: 
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5. Move the mouse pointer to an appropriate position on the blank ACD/ChemSketch page 
created in the previous section, and click to insert the structure: 

N

N

N

N

O

O

CH3

CH3

CH3

 
Note For more details on the ACD/Dictionary options, refer to the ACD/Dictionary User’s 

Guide located in the ACD/Labs documentation folder (\\DOCS\DICT.PDF). 

2.5 Flipping Structures 

You can rotate or flip the entire structure with a single button click using a set of tools on the 
Structure toolbar. 

1. Take the structure of caffeine from the Dictionary as described in the previous section or draw 
it manually.  We are going to rotate the structure relative the double bond indicated with red 
line in the image below: 

 

2. On the Structure toolbar, click Set Bond Horizontally , and then click the bond to set it 
horizontally, rotating the rest of the structure correspondingly: 

Note Repetitive clicking the bond with this tool will rotate it around the clicked bond. 

 

3. On the Structure toolbar, click Set Bond Vertically , and then click the bond to set it 
vertically, rotating the rest of the structure correspondingly: 
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4. On the Structure toolbar, click Flip on Bond , and then click the bond, the structure will 
rotate around the bond clicked: 

 
Note The CHAPTER2.SK2 file (Page 2/2) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

5. Select the entire structure (or any fragment). 

6. On the Structure toolbar, click Flip Top to Bottom , and the selected structure or 
fragment (or if nothing is selected, then all of the structures drawn in the workspace) will rotate 
upside-down. 

7. Similarly, click Flip Left to Right  to flip the selected structure or fragment (or, if nothing is 
selected, then all of the structures drawn in the workspace) from left to right. 

Note Applying the Flip tools may change the stereo configuration.  To control this, from 
the Options menu, choose Preferences, and then switch to the Structure tab.  
The Keep Stereo Configuration on area controls whether the program will 
remember the “true” 3D arrangement of the structure: 

   
We recommend that the Flips check box be selected.  In this case, the structure 
before the flip is the same as the structure after the flip, although its representation 
has changed: 

   Cl

CH3

Br
H

Cl

CH3

Br
H

Yes

 
If the Flips check box is cleared, the structures before and after the flip are 
enantiomers: 

   Cl

CH3

Br
H

Cl

CH3

Br
H

No
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2.6 Output 

As soon as you have drawn one or more structures, you can save them to a file, print them, or 
insert them into the other applications such as MS Word, Excel, etc.  You can also use the drawn 
structure(s) to try out the ACD/I-Lab services (for more information, refer to the ACD/I-Lab User’s 
Guide located in the ACD/Labs documentation folder, \\DOCS\ILAB.PDF). 

2.6.1 Saving ACD/ChemSketch Document to ChemSketch (.SK2) File 

Let us save the entire ACD/ChemSketch document with the structures created in previous 
sections in the default proprietary ACD/Labs format as a file which we will call EXAMPLE1.SK2. 

1. From the File menu, choose Save. 
2. In the Save Document As dialog box that appears, specify the name and location of the file to 

which the work should be placed, and click Save. 

Note If you want to change the name or location of an existing .SK2 file, from the File 
menu, choose Save As. 
 
To save all of the open documents at once, from the File menu, choose Save All. 

2.6.2 Saving Structure to MDL Molfile 

A standard format shared by many programs is the molfile format, developed by MDL, Inc.  Note 
that it will not retain graphical images, text, etc.  It only retains molecular structures. 
1. Select the structure you want to save. 
2. From the File menu, choose Export to display the corresponding dialog box. 
3. Specify the name and location of a molfile to be created. 
4. In the Save as type box, select MDL Molfiles [V2000] (*.mol): 

 
5. Click Save. 
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2.6.3 Printing ACD/ChemSketch Document 

Another way to preserve your work is to print a report. 

Before start printing, verify the page setup settings: 
1. From the File menu, choose Page Setup to display the corresponding dialog box where you 

can specify the paper size, orientation, margins for the page, and (if you wish) set options for 
the poster (for more details on the poster creation, refer to Section  10.3): 

 
2. Click OK to save settings. 

Now, you are ready to print your work: 

1. On the General toolbar, click Full Page  to see how the page will look on a printout. 
2. If necessary, move the objects on the page to arrange them properly. 

3. From the File menu, choose Print or, on the General toolbar, click  to display the Print 
dialog box where you can specify the page range and the number of copies to be printed. 

4. Click Print . 
5. Keep the EXAMPLE1.SK2 file open. 

2.6.4 Embedding ACD/ChemSketch Structure into Third-Party Document 

Sometimes you may need to insert the structure into a report written in MS Windows applications 
other than ACD/ChemSketch (e.g., Word document, Excel spreadsheet, etc.): 

1. Select the required structure(s) in the ACD/ChemSketch page. 
2. Copy the selection to the Clipboard using one of the following ways: 

• On the General toolbar, click Copy ; 
• From the Edit menu, choose Copy; or 
• Press CTRL+C. 
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3. Switch to the application where you want the structure(s) to be inserted, and paste the 
Clipboard contents using the Paste command of that application. 

Important When pasting structures copied from ACD/ChemSketch to third-party 
applications (e.g., Microsoft Excel), the structure may be represented as a set 
of numbers and figures (as an MDL molfile). 
To place a picture of the structure, use the Paste Special command in the 
application you are pasting to.  Among the paste options, choose either the 
ACD ChemSketch Object or Picture (Windows Metafile) option.  The 
former inserts the structure as an OLE object thus allowing you to edit the 
inserted structure via ACD/ChemSketch later by double-clicking the picture. 
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3. Drawing More Complex Structures 

3.1 Objectives 

Now that you have studied the basics of structure drawing described in Chapter 2 you may want 
to draw more complex structures using the advanced tools of ACD/ChemSketch. 

In this chapter, you will learn how to: 
• Use the Table of Radicals to draw typical chemical fragments; 
• Quickly draw ring structures; 
• Delete and replace atoms; 
• Set an atom’s charge; 
• Draw cations and anions; 
• Specify type of bonds (double, triple, coordination, Markush, etc.); 
• Generate stereo descriptors; and 
• Change various atomic properties. 

3.2 Using the Table of Radicals 

The Table of Radicals includes pre-drawn structures of amino acids, their protecting groups, as 
well as nucleotides and other frequently used radicals. 
1. With the EXAMPLE1.SK2 file still open in the workspace, on the General toolbar, click New 

Page  to start new drawing in a new page (Page 3) of the same document. 
2. To illustrate the work with the Table of Radicals, clear the References toolbar: double-click 

blank space of the References toolbar, and then, in the message box that appears, click Yes.  
The radical buttons will be removed from the toolbar. 

Tip To turn the References toolbar to the default view, right-click the toolbar, and then, in 
the shortcut menu that appears, select Reset Toolbar. 
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3. On the References toolbar, click Table of Radicals  to display the corresponding panel: 

  

4. Under Cycles, click Cyclohexane  to place and select a Cyclohexane button on the 
References toolbar on the right side of the screen while closing the panel.  Note that the 
template’s outline is attached to the mouse pointer. 

5. Repeat Steps 3-4 for Cyclopentane  and Carboxyl  to place their buttons on the 
References toolbar as well: 
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3.3 Using Ring Structures 

Now, we shall draw a structure of hexadecahydrocyclopenta[c]fluorene-3,4,5,7,8,9-
hexacarboxylic acid: 

1. On the References toolbar, click Cyclopentane . 
2. Click in the workspace to paste a five-membered ring. 

3. On the same toolbar, click Cyclohexane . 
4. Now point to the bond as shown below,

 
 and then click to create the following octahydro-1H-

indene structure: 

 
5. Repeat these steps to create the following structure: 

 

 

6. On the Structure toolbar, click Set Bond Vertically  then click the bond as shown below 
to rotate the structure around this bond to obtain the following: 

 

7. On the References toolbar, click Carboxyl . 
8. Click the indicated atoms to sprout carboxyl groups from them to obtain the following acid: 

 
Note The CHAPTER3.SK2 file (Page 1/7) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
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3.4 Deleting Atoms and Groups 

In the drawn structure, we are going to delete the indicated atoms (i.e., oxo- and hydroxyl 
groups): 

 

You can do this in two ways: 
• By deleting each atom one by one (as covered in Section  2.2.4); or  
• By deleting several atoms simultaneously (as described in the following section). 

3.4.1 Deleting Several Atoms Simultaneously 

With the help of the Lasso tool (introduced in Section  2.2.12), you can delete all of the required 
structural elements at once: 

1. On the Structure toolbar, ensure that the Lasso selection mode  in on.  Note that the 

Select/Move  tool becomes active. 
2. Drag to include all of the specified atoms in the closed Lasso line to select them: 

 

Note The red line on this picture shows the suggested path of enclosing the desired 
groups into selection, and it will not appear as such in your workspace.  Only the 
atoms within the lassoed space will be selected individually. 

3. In case of inaccurate selection, click anywhere in the empty space of the page to deselect all 
of the atoms, and then try to select them again. 

Tip You can also select the atoms one by one or by several groups while holding down 
SHIFT. 
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4. Delete all of the selected atoms of the structure by pressing DELETE: 
CH3

CH3

CH3

CH3

CH3

O

 
Note The CHAPTER3.SK2 file (Page 1/7) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

3.5 Replacing Atoms and Groups 

Now, let’s replace the indicated carbon atoms and methyl groups with atoms of nitrogen and 
oxygen: 

 

1. Ensure that the Draw Normal  drawing tool is selected on the Structure toolbar. 

Note You cannot replace atoms with the Draw Continuous  tool (for more details on 
this tool, refer to Section  2.2.8). 

2. On the Atoms toolbar, click Nitrogen , and then click all of the atoms and groups indicated 
with arrowed cycles on the above structure: 

NH

N N
H

NH

N

NH2

NH2

CH3

CH3

CH3

N

O

 

ACD/ChemSketch Tutorial 26 



Drawing More Complex Structures 

3. On the Atoms toolbar, click Oxygen , and then click the three methyl groups indicated 
with red rectangles. 

NH

N N
H

NH

N

NH2

NH2

OH

OH

OH

N

O

 
Note The CHAPTER3.SK2 file (Page 1/7) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

3.6 Setting Double Bonds 

Finally, we shall draw double bonds in the structure: 

1. With any of the Draw Normal , Draw Continuous , or Draw Chains  tools active, 
click single bonds indicated below to turn them to double bonds: 

Tip Example of triple bonds drawing is given in Section  2.2.2. 

 

2. Using the Change Position button , the structure’s appearance can be “fine-tuned”.  Click 
this button on the Structure toolbar, and then click the indicated hydrogens and double bonds.  
Note the movement of hydrogen around the nitrogen and oxygen, and the double bond 
around the single bond: 

 
Note The CHAPTER3.SK2 file (Page 1/7) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

3. On the General toolbar, click Save File , then click New Page . 
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3.7 Setting Charges and Defining Anions and Cations 

In the new ACD/ChemSketch page (Page 4), we will draw the following set of structures: 

NH2
+

CH3

CH3

 N
-

CH3

CH3

 N CH3

CH3

 

 

anion free radical  cation 

NH CH3

CH3

   NH
+

CH3

CH3

 
radical cation radical anion singlet biradical triplet biradical 

 

1. On the Atoms toolbar, click Carbon  (making sure that the Draw Normal  tool 
becomes active), and then click three times at the same point of the workspace to draw the 
following propane structure: 

CH3

CH3

 

2. On the Atoms toolbar, click Nitrogen , and then click the middle carbon atom to replace it 
with the nitrogen one: 

 
3. Select the created N-methylmethanamine structure, press CTRL+C to copy it to the Clipboard, 

and the paste five more duplicates of the structure below the first one by pressing CTRL+V 
repeatedly. 

4. On the Atoms toolbar, click the lower right triangle of the Increment (+) Charge  to 
expand the Charges/Radicals menu containing the following buttons: 

  Increment (+) Charge 

  Decrement (–) Charge 

  Radical 

  Positive Radical Ion 

  Negative Radical Ion 

5. From the Charges/Radicals menu, choose Decrement (–) Charge  tool (note that the 

mouse pointer is changed to ), and then click the NH group of the topmost structure to 
make it a dimethylazanide anion: 

N
-

CH3

CH3
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6. Right-click within the workspace to quickly switch mode of to the mouse pointer to  (or 

choose the corresponding Increment (+) Charge  tool from the Charges/Radicals menu), 
and click the NH group of the second structure to make it an N-methylmethanaminium cation: 

NH2
+

CH3

CH3

 
Note When you change the charge of a nonmetal atom using the Increment (+) 

Charge  or Decrement (–) Charge  tools, the corresponding number of 
hydrogen atoms is automatically added to it, or removed from it, to preserve proper 
chemical valence.  If you change the charge of a metal atom, the charge is 
changed in increments or decrements in accordance with the next chemically valid 
charge of the corresponding ion. 
You can view common valences in the Periodic Table of the Elements dialog box 
(for more information, refer to Section  2.2.7). 

7. From the Charges/Radicals menu, choose Radical  (the mouse pointer is changed 

accordingly to ), and click the NH2 group of the third structure to draw a free dimethylamin 
radical: 

N CH3

CH3

 

8. Right-click in the workspace to quickly switch mode of to the mouse pointer to  (or 

choose the corresponding Positive Radical Ion  tool from the Charges/Radicals menu), 
and click the NH group of the fourth structure to draw the dimethylamin radical cation: 

NH
+

CH3

CH3

 

9. Right-click in the workspace to quickly switch mode of to the mouse pointer to  (or 

choose the corresponding Negative Radical Ion  tool from the Charges/Radicals menu), 
and click the NH group of the fifth structure to draw the dimethylamin radical anion: 

NH CH3

CH3

 

10. On the General toolbar, click Delete , and then click one methyl group in the last structure 
to turn it to methanamine. 

11. From the Charges/Radicals menu, choose Radical , and click the NH group of the 
methanamine structure two times until the following singlet methylimin biradical is obtained: 
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12. Click the structure again with the radical tool to obtain the triplet methylimin biradical: 

 
Note The CHAPTER3.SK2 file (Page 2/7) with these seven structures can be found in 

the ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

13. On the General toolbar, click Save File , then click New Page . 

3.8 Drawing Markush Bonds 

To denote structures with an undefined attachment point, you can use one of the Markush Bond 
tools provided by ACD/ChemSketch: 

 

1. On the References toolbar, click Table of Radicals  to display the corresponding panel. 

2. On the panel, click Benzene , and then click in the workspace to paste the benzene 
structure. 

3. On the Atoms toolbar, click Carbon  (note that the Draw Normal  tool is automatically 
enabled). 

4. Click the topmost atom of benzene structure to sprout up a methyl group creating toluene: 
CH3

 

5. On the Atoms toolbar, click Bromine . 

6. Using the Select/Move  tool, select five lower atoms of the structure: 
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7. On the Structure toolbar, click either Markush Bond  or Markush Bond with 

Shadow  tool.  The selected bromine atom appears connected by the Markush bond: 
CH3

Br
 OR 

CH3

Br
 

On this structure, the Br atom might be connected to any of the five carbon atoms of toluene. 

Note The CHAPTER3.SK2 file (Page 3/7) with these structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

3.8.1 Markush Bond with Added or Removed Fragment 

Starting with version 9.0, you can draw structures with the attached mass or formula difference 
values, instead of the added or removed structural fragments itself.  This special type of Markush 
structures is useful for designation of metabolic or mass-spectral transformations of chemical 
structures. 
1. Draw toluene structure and select non-substituted carbon aromatic atoms of the structure as 

described in the previous section. 
2. On the Structure toolbar, click Markush Bond with Added or Removed Fragment button: 

either Added or Removed Fragment  or Added or Removed Fragment with 

Shadow . 
3. In the Define Markush Mass Difference dialog box that appears, select both the Addition 

and Mass options, and then, in the adjacent box, type 79.9: 

 
4. Click OK.  You will see one of the following structures: 

CH3

[+79.9]
 OR 

CH3

[+79.9]

 
Note The CHAPTER3.SK2 file (Page 3/7) with these structures can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
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5. On the General toolbar, click Save File , then click New Page . 

3.9 Generating Stereo Descriptors 

ACD/ChemSketch allows you to generate stereo descriptors for chiral and pseudo chiral centers, 
and for a double-bond configuration. 
1. On the blank ACD/ChemSketch page ( Page 6), draw the following set of structures using the 

drawing tools described above: 

CH3

CH3

Cl

CH3 CH3

Cl
CH3 CH3

(2Z)-4-chloropent-2-ene (2E)-4-chloropent-2-ene 1,4-dimethylcyclohexane
 

2. On the Structure toolbar, click Down Stereo Bonds . 
3. Draw the down stereo bond of the chloro substituent in the (2Z)-4-chloropent-2-ene structure 

by clicking the corresponding single C–Cl bond: 

CH3

CH3

Cl  

4. On the Structure toolbar, click Up Stereo Bonds , and repeat the previous step to draw 
the up stereo bonds in the other two structures as follows: 

CH3 CH3

Cl
CH3 CH3

 
Tip To draw a new stereo bond, either drag from the atom to an empty space, or simply 

click an existing atom (if the existing atom is of the same type as that currently active 
on the Atoms toolbar). 
To change the direction of a stereo bond, click this bond repeatedly. 

5. Select all of the structures. 

Note If no structure(s) is(are) selected in the workspace, stereo descriptors are 
automatically generated for all structures on the current page which have stereo 
centers or double bonds for which Z/E or R/S isomerism is possible. 
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6. On the Tools menu, point to Generate, and click Stereo Descriptors (this command 
available both in Structure and Draw modes).  Stereo descriptors appear on the selected 
structures near the corresponding chiral centers and double bonds: 

CH3

CH3

Cl

CH3 CH3

Cl
CH3 CH3

Z S

E

R
ss

 
 

Note The CHAPTER3.SK2 file (Page 4/7) with these structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
 
The following stereo descriptors are available: 
• S and R describe a chiral center configuration. 
• E and Z describe a double-bound configuration. 
• Small r and s describe configurations of pseudo chiral centers. 

To change the color of stereo descriptors: 
1. From the Options menu, choose Preferences to display the Preferences 

dialog box. 
2. Switch to the Structure tab, and then select the appropriate color in the 

Auto/Manual Numbering Color box.  The next time you generate stereo 
descriptors, the new color will be used. 

7. On the General toolbar, click Save File , then click New Page . 

3.10 Drawing Coordination Bonds 

There are numerous ways to draw coordinating bonds.  ACD/ChemSketch allows you to draw 
four different types. 

We are going to draw the following structure: 

CH3
O

O

O
CH3

Li

{1-(methoxy-κO)-2-[2-(methoxy-κO)ethoxy-κO]ethane}(phenyl)lithium
 

1. On the References toolbar, click Benzene , and paste the benzene ring to the 
workspace: 
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2. On the Structure toolbar, click Set Bond Horizontally , and then click the bond as shown 
below to rotate the ring: 

 

3. On the Structure toolbar, click the Draw Continuous  tool. 

4. On the Atoms toolbar, click Periodic Table  to display the Periodic Table of Elements 
dialog box. 

5. Click Lithium  to select it, and then click OK while adding the corresponding button on the 
toolbar. 

6. Double-click the leftmost carbon atom in the ring to sprout the Li substituent: 

 

7. On the Structure toolbar, click Draw Chains , and then, on the Atoms toolbar, click 
Carbon . 

8. Holding down SHIFT, drag vertically down so that the chain being generated contains 9 
elements. 

Tip If the Informative Cursor option is selected in the Preferences dialog box (General 
tab), you will see the number of elements hang near the cursor when you draw the 
chain. 

9. After dragging, select the chain, and move to the left of the drawn structure not touching it: 

 

10. Switch to the Draw Normal  tool, and, on the Atoms toolbar, click Oxygen . 
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11. Click the buttons indicated in the picture below to replace them with the oxygen atoms: 

 

6. On the Structure toolbar, click the white triangle of the Coordinating Bonds  tool, and 

choose the Coordinating (Dashed Arrow) Bonds  tool from the menu. 
7. Drag from one of the oxygen atoms to the Li atom to connect them with the coordinating bond.  

As you release the mouse button, the bond appears: 

 
Note If the bond arrow is directed the wrong way, point to the bond so that it is 

highlighted, and click to change the direction. 
8. In the same manner, drag from other oxygen atoms to Li to draw other bonds: 
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9. Click Clean Structure  to standardize all the bond lengths and angles: 

CH3
O

O

O
CH3

Li

 

To practice different Coordinating Bonds tools (Coordinating (Dashed) Bonds  and 

Coordinating (Solid) Bonds ), you can also try drawing the following coordination bonds: 

CH3
O

O

O
CH3

Li

CH3
O

O

O
CH3

Li

 
Note Even looking as common bonds, coordinating bonds do not affect valences and 

charges of connected atoms.  All the types are coded in the same way, so all the 
three drawings above describe the same structure. 
 
The CHAPTER3.SK2 file (Page 5/7) with these three structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

10. On the General toolbar, click Save File , then click New Page . 

3.11 Delocalized Charges and Curves 

The delocalized bonds and charges can be used to draw reaction intermediates, delocalized 
charges and organometallic structures with multicentral coordination. 

To practice this type of bonds, we are going to draw the following structure: 

CH3

CH3

CH3

Br H

+

 

1. On the References toolbar, click Cyclohexane , and paste cyclohexane structure into 
the workplace. 

2. On the Atoms toolbar, click Carbon . 
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3. By clicking the carbon atoms in meta positions of the ring, sprout the CH3 groups: 

 

4. On the Atoms toolbar, click Bromine , and drag from the upper carbon atom of the ring to 
sprout a new bond: 

 

5. Click Hydrogen , and drag from the same atom to sprout one more bond: 

 

6. Click the Select/Move  button. 
7. Hold down SHIFT and click one by one the bonds so that they become selected, as shown on 

the picture below: 
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8. On the Structure toolbar, click the Solid Delocalization Curve  tool (it is selected by 
default from the Delocalization Curve tools menu) to apply it to the selected bonds: 

 

9. On the Atoms toolbar, click Increment (+)Charge , then point to the center of the 
delocalized bonds so that the highlighting appears, and click to change the charge to “+”: 

 
Note If you want to make the plus sign more prominent, you can change its size by 

changing the properties as described in Section  3.13 below. 
10. Now, try to draw the following structure yourself using another Delocalization Curve tool 

(Dotted Delocalization Bond ) to practice the delocalized bond drawing: 

CH3 CH3

+

 
Note The CHAPTER3.SK2 file (Page 6/7) with these two structures can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

11. On the General toolbar, click Save File , then click New Page . 
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3.12 More Bond Types 

In this section, we are going to draw the following structure which contains undefined double and 
single stereo bonds.  This denotes that configurations of double bond or chiral center is not 
known or not taken into account. 

 
2-methyl-1-[2-(phenyldiazenyl)phenyl]butan-2-ol 

1. Alternately applying the Benzene  and Cyclohexane  tools from the References 
toolbar, draw the following structure as shown below: 

 

Tip On the Structure toolbar, click Set Bond Horizontally  to rotate the first inserted 
benzene template. 

2. On the General toolbar, click Delete , and then click central single bond between 
benzene rings to remove it. 

3. On the Atoms toolbar, click Nitrogen , and click CH2 groups to replace them with NH 
ones: 

NH NH

 

ACD/ChemSketch Tutorial 39 



Drawing More Complex Structures 

4. On the Atoms toolbar, click Carbon , and add 2-methylbutyl fragment by sequentially 
clicking the atoms as shown below: 

 

5. On the Atoms toolbar, click Oxygen , and then drag from the indicated atom left and up 
to sprout an hydroxyl group: 

 

6. On the Structure toolbar, click the white triangle of the Undefined Stereo Bonds  button 
to display Special Bonds menu containing more bond types. 

7. Click Undefined Double Stereo Bonds  to select it, and then click the indicated single 
bond to replace it with the undefined type: 

 
8. From the same Special Bonds menu of the Structure toolbar, choose Undefined Stereo 

Bonds , and click the C–OH bond to replace it with the undefined type: 

 
As a result, the structure shown at the beginning of this section should be created. 
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9. To practice the drawing of other bond types available from the Special Bonds menu, try to 
draw the following structures: 

• Hollow wedges  are used sometimes to describe spatial arrangement of atoms. 

Hollow bonds are equal to more common up stereo bonds : 
Cl

CH3 CH3

H
Cl

CH3 CH3

H

 

• Delocalized  and partial order  bonds can be used to describe delocalization of 
double bonds, tautomeric or aromatic structures: 

O
CH3

CH3 

• Quadruple bonds  are used to describe the structure of some organometallic 
complexes: 

N

N N

Ph

Ph
-

N

NN

Ph

Ph
-

N

NN

Ph

Ph
-

Cr2+

N

N N

Ph

Ph
-

Cr2+

 
Note The CHAPTER3.SK2 file (Page 7/7) with these five structures can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
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3.13 Changing Atom Properties 

If you want to display the valence or the isotopic mass of an atom of a structure drawn in 
ACD/ChemSketch—or even change the typeface or the size of the atom identification—you 
should use the Properties panel. 

You can use the structure drawn in Section  3.11 on the ACD/ChemSketch page 8 of the example 
document.  We are going to change the size of the plus sign and make the visible atom symbols 
bold: 

CH3

CH3

CH3

Br H

+

 
Note The CHAPTER3.SK2 file (Page 6/7) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

1. On the Structure toolbar, click Select/Move . 
2. Point to the plus sign in the structure, and double-click.  The Properties panel with the Atom 

tab active appears: 

  
As you can see, the buttons located below the preview area allow you to specify the style 
settings for seven possible atom attributes: Atom Symbol ( ), Hydrogen ( ), Hydrogen 
Index ( ), Charge ( ), Valence ( ), Isotope ( ), and Numbering ( ). 
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3. In the drop-down list adjacent to the Font, select 14: 

  
4. Click Apply  to view the result on the selected element: 

 
5. By selecting other structure parts or the whole structure and double-clicking the selection, try 

modifying various attributes in the Properties panel; after all click the rightmost button on the 
title bar of the panel to close it. 

6. On the General toolbar, click Save File , then click Close Document . 
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4. Advanced Structures, SMILES and InChI 
Notations, and Reaction Schemes 

4.1 Objectives 

This chapter is the next step to drawing even more sophisticated structures.  Two kinds of 
optimization are covered: optimizing for display purposes (2D) and optimizing according to a 
simple force-field model (3D).  If you are using ACD/ChemSketch for the first time, it is 
recommended that you do the exercises described here only after completing the previous 
chapters. 

In this chapter, you will learn how to: 

• Draw structures of cyclic alkanes and peptides using the Clean Structure  tool for 2D-
optimization; 

• Convert structures to SMILES format and vice versa; 
• Convert structures to InChI string and vice versa; 

• Use the 3D Optimization  tool for drawing “spectacular” 3D structures of 
Bicyclo[2.2.2]octane, triptycene, cubane, and dodecahedrane; 

• Draw reaction schemes and reflect the reaction conditions on it; 
• Map reactions; and 
• Use the Reaction Calculator. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Structure mode of ACD/ChemSketch. 

4.2 2D-Optimization 

The Clean Structure  tool can be applied for a 2D-optimization of the drawn structure, i.e. 
redrawing and resizing it to standardize all the bond lengths and angles.  Using this tool, you can 
easily draw perfect structures as demonstrated in the examples below. 

4.2.1 Creating the Structure of Cyclic Alkanes 

Using the following technique, you can quickly draw cyclic alkanes. 

Here's how to draw a cyclononane structure: 

1. Being in the new blank ACD/ChemSketch document, on the Atoms toolbar, click Carbon . 
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2. On the Structure toolbar, click Draw Chains , and drag in the workspace to draw a 9-
member chain on nonane: 

CH3 CH3 
Tip If the Informative Cursor option is selected in the Preferences dialog box (General 

tab), you will see the number of elements hang near the cursor when you draw the 
chain. 

3. On the Structure toolbar, click Flip Top to Bottom  to turn the structure upside down (this 
step is optional): 

CH3 CH3 

4. Right-click to quickly switch to the Draw Normal  tool, and drag from one terminal carbon 
atom to another in order to connect them with a bond: 

. 

5. On the Structure toolbar, click Clean Structure  to obtain the following cycle: 

 
6. Try to draw C10- and C8-rings using the above technique. 

Note The CHAPTER4.SK2 file (Page 1/9) with these three structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

7. On the General toolbar, click Save File , in the Save Document As dialog box that 
appears, specify the name and location of the file to which the work should be placed, and 
click Save. 

8. On the General toolbar, click New Page . 
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4.2.2 Creating the Structure of a Cyclic Peptide 

 This section is based on the PEPT.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

Let’s draw the cyclic Tyr-Ala-Trp peptide using the Clean Structure  tool: 

O

NH
OH

N
H

O
NH

CH3

O N
H

  

1. On the General toolbar, click the Open Template Window  button to display the 
Template Window dialog box, and switch to the Amino Acids tab. 

Note If the Amino Acids tab is absent at the left part of the dialog box, choose its name 
from the leftmost drop-down list at the top of the dialog box. 

2. Ensure that the 1(4) Acids set of amino acids is chosen in the rightmost drop-down list at the 
top of the dialog box. 

3. Click the template of Tyrosine (not its name), and then click within the workspace to paste the 
structure. 

4. From the Table of Radicals (for more information, refer to Section  3.2), choose sequentially 

Alanine  and Tryptophan , and attach the corresponding radicals as follows: 

 
Tip You can flip the template’s outline before placing it in the workspace by pressing TAB. 

5. Right-click to quickly switch to the Select/Move  tool, and drag the NH2 group to the OH 
group as shown: 
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6. On the Structure toolbar, click Clean Structure  to obtain the required structure. 
7. Using selection and rotation tools from the Structure toolbar, bring the structure to the desired 

appearance. 

Note The CHAPTER4.SK2 file (Page 2/9) with this structure can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

8. Try to draw any other cyclic peptide, for instance Gramicidine S: 

 

4.3 SMILES Notations 

ACD/ChemSketch can convert SMILES (Simplified Molecular Input Line Entry Specification) 
strings to structures, and convert structures to SMILES. 

4.3.1 Generating SMILES Notations 

Let’s create a SMILES string for the cyclic peptide drawn in Section  4.2.2. 
• On the Tools menu, point to Generate, and then choose SMILES Notation.  The 

generated string appears right below the structure: 
O

NH
OH

N
H

O
NH

CH3

O N
H

Oc1ccc(cc1)CC4NC(=O)C(C)NC(=O)C(Cc3cnc2ccccc23)NC4=O  
You can now select the text string and press CTRL+C to copy it to the Clipboard, and then paste 
it into any external text editor (e.g., Windows Notepad) as text using the Paste command from 
the editor’s menu or by pressing CTRL+V. 

Note If you have several structures drawn on one page and you want to generate the 
SMILES string for all of them, you do not have to select them all—just leave them 
all unselected, and repeat the generation procedure.  The SMILES notation 
appears for all the drawn structures as one string where each notation is separated 
by a point. 
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4.3.2 Generating Structures from SMILES Notations 

Now we will try the inverse task: generation of structures from the SMILES strings. 

At first, we will generate the structure from the notation created in the previous section. 
1. Select the text string created in the previous section: 

 
2. On the Tools menu, point to Generate, and then choose Structure from SMILES.  The 

generated structure is placed below the text string.  As you can see, it is the same structure 
from which the SMILES notation that was generated in the previous section: 

 
Note The CHAPTER4.SK2 file (Page 2/9) with these structures can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

If you do not have the text string inserted into the workspace or it is not selected, selecting the 
Structure from SMILES command displays the following dialog box where you can enter the 
string manually—for example the string for benzene: 
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3. Click OK.  The generated structure is attached to the cursor as an outline: 

 
4. Click in the workspace to place the structure. 

5. On the General toolbar, click Save File , then click New Page . 

4.4 InChI Notations 

ACD/ChemSketch can convert InChI (IUPAC International Chemical Identifier) notations to 
structures, and convert structures to InChI strings. 

InChI procedures were developed under IUPAC project.  The technical development was carried 
out primarily at the US National Institute of Standards and Technology (NIST).  More information 
about InChI is available on the IUPAC Web site at: 

http://www.iupac.org/inchi/ 

4.4.1 Generating InChI Notations 

Let’s create an InChI string for (1S)-1-(1H-imidazol-4-yl)ethanol. 
1. Using the obtained skills, draw the following structure: 

CH3

NHN

OH

 
2. On the Tools menu, point to Generate, and then choose InChI Options. 
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3. In the dialog box that appears, specify the options as shown below, and click OK: 

 
4. On the Tools menu, point to Generate, and then choose InChI for Structure.  The generated 

string appears right below the structure: 
CH3

NHN

OH

InChI=1/C5H8N2O/c1-4(8)5-2-6-3-7-5/h2-4,8H,1H3,(H,6,7)/t4-/m0/s1  
Note The CHAPTER4.SK2 file (Page 3/9) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

You can now select the text string and press CTRL+C to copy it to the Clipboard, and then paste 
it into any external text eitor (e.g., Windows Notepad) as text using the Paste command from the 
editor’s menu or by pressing CTRL+V. 

Note If you have several structures drawn on one page and you want to generate the 
InChI string for all of them, you do not have to select them all—just leave them all 
unselected, and repeat the generation procedure.  The InChI notation appears for 
all the drawn structures as one string. 

5. Repeat the generation of the InChI string for the current structure with the different options: in 
the InChI Options dialog box, clear the Mobile H Perception option and select Ignore under 
Stereo Options.  The following InChI notation appears in this case: 

InChI=1/C5H8N2O/c1-4(8)5-2-6-3-7-5/h2-4,8H,1H3,(H,6,7)/f/h6H 

ACD/ChemSketch Tutorial 50 



Advanced Structures, SMILES and InChI Notations, and Reaction Schemes 

4.4.2 Generating Structures from InChI Notations 

Now we will perform the inverse task: generation of a structure from an InChI string.  We will 
generate the structure from the notations created in the previous section. 
1. Select the text string that was created first in the previous section: 

 
2. On the Tools menu, point to Generate, and then choose Structure from InChI.  The 

generated structure is placed below the text string.  As you can see, it is the same structure 
from which the InChI notation was generated in the previous section: 

 
3. Now select the second InChI string, and choose the Structure from InChI command again.  

You can see that the stereoisomerism is not reflected in this case: 

InChI=1/C5H8N2O/c1-4(8)5-2-6-3-7-5/h2-4,8H,1H3,(H,6,7)/f/h6H

CH3

NH
N

OH

 
Note The CHAPTER4.SK2 file (Page 3/9) with these three structures can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

4. On the General toolbar, click Save File , then click New Page . 
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4.5 3D-Optimization 

This section explains how to create structures that have “realistic” angles and bond lengths.  
There is no need to explain how difficult it is to draw such structures proportionally.  The 3D-
Optimization and 3D Rotation options will help you to quickly cope with this task.  These options 
make it possible to create complex structures in ACD/ChemSketch with ease. 

4.5.1 Creating Structure of Bicyclo[2.2.2]octane 

 This section is based on the BICYC.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

Using the following technique, you can quickly draw bicyclic alkanes. 

Here's how to draw a bicyclo[2.2.2]octane structure: 

 
1. From the Options menu, choose Preferences, and then, in the dialog box that appears, 

switch to the Structure tab. 
2. In the 3D Optimization area, clear the Add Hydrogens check box, and click OK. 

3. On the References toolbar, choose Cyclohexane , and click in the workspace to place a 
cyclohexane ring. 

4. Click Draw Normal , and draw the hydrocarbon bridge by dragging as shown in the 
following scheme: 

 

ACD/ChemSketch Tutorial 52 



Advanced Structures, SMILES and InChI Notations, and Reaction Schemes 

5. On the Structure toolbar, click 3D Optimization  to obtain a 3D model of the drawn 
structure: 

 
Note If there is more than one structure in the workspace, you should select the 

structure you want to optimize in 3D using any of the selection tools: Select/Move 

, Select/Rotate/Resize , or 3D Rotation . 
6. If the Switch to 3D Rotation mode check box on the Structure tab of the Preferences 

dialog box (Options menu) is selected, you will be automatically switched to 3D Rotation 

mode after the 3D Optimization is completed.  If you are not, click 3D Rotation  on the 
Structure toolbar. 

7. Point to any atom or bond on the structure and drag over the workspace to rotate the structure 
until it is placed as shown: 

 
Note You can choose whether the background bond will be broken or not in the 

structure: 
1. From the Options menu, choose Preferences, and then switch to the 

Structure tab of the dialog box that appears. 
2. In the Bonds Intersections area, select or clear the Enable check box. 

 
You can change the position of intersecting bonds by applying the Bring Bond to 
Front (CTRL+F) or Send Bond to Back (CTRL+K) commands (Tools menu) to 
the selected bond.  You can also bring the background bond to the front by clicking 

it with the Change Position  tool active while holding down SHIFT. 
8. Using the above technique, draw the following bicyclic structures on your own: 

Bicyclo[2.2.1]heptane 

 
Bicyclo[3.2.1]octane 

 
You can also choose the above structures from the corresponding templates in the Template 
Window dialog box.  For more information on this dialog box, refer to Section  5.5. 

Note The CHAPTER4.SK2 file (Page 4/9) with these three structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9. On the General toolbar, click Save File , then click New Page . 
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4.5.2 Creating the Structure of Triptycene 

 This section is based on the TRIPTYC.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

 
1. Draw the structure of bicyclo[2.2.2]octane as described in the section above. 

Tip You can also select corresponding template on the Bicyclics tab of the Template 
Window dialog box (for more information, refer to Section  5.5), and paste it in the 
workspace.  If the tab is absent at the left part of the dialog box, choose its name from 
the leftmost drop-down list at the top of the dialog box. 

2. On the References toolbar, choose Benzene . 
3. Point to the bond a, and click to attach the benzene ring to this bond: 

 
4. Repeat step 3 for bonds b and c to obtain the following structure of triptycene: 

 

5. On the Structure toolbar, click 3D Optimization  to obtain a 3D-model of the drawn 
structure: 

 
6. If the Switch to 3D-Rotation Mode check box on the Structure tab of the Preferences 

dialog box (Options menu) is selected, the program will automatically switch to the 3D 

Rotation mode after the 3D optimization is completed.  If it does not, click 3D Rotation  on 
the Structure toolbar. 

7. Point to any atom or bond of the structure and drag over the workspace to obtain the 
projection you want (for details, refer to the previous section). 
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8. From the Tools menu, choose Show Aromaticity to show the aromatic rings. 

Note The CHAPTER4.SK2 file (Page 5/9) with these structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9. On the General toolbar, click Save File , then click New Page . 

4.5.3 Creating Structure of Cubane 

Using the following technique, you can quickly draw bridged polycycles. 

Here's how to draw a cubane structure. 

 

1. On the References toolbar, click Table of Radicals , and then choose 

Cyclobutane . 
2. Click within the workspace to place 4-membered ring, and once again to place another ring 

below the first one. 

3. On the Structure toolbar, click Draw Normal , and connect the corners of the cyclobutane 
structures with bonds by dragging from one atom to another as shown: 

 

4. On the Structure toolbar, click 3D Optimization  to obtain the 3D model of the drawn 
structure. 

5. On the Structure toolbar, click 3D Rotation  if it is not already selected. 
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6. Point to any atom or bond on the structure, and drag over the workspace to obtain the 
projection you want: 

 
Note You can choose whether the background bond will be broken or not in the 

structure: 
1. From the Options menu, choose Preferences, and then switch to the 

Structure tab of the dialog box that appears. 
2. In the Bonds Intersections area, select or clear the Enable check box. 

 
You can change the position of intersecting bonds by applying the Bring Bond to 
Front (CTRL+F) or Send Bond to Back (CTRL+K) commands (Tools menu) to 
the selected bond.  You can also bring the background bond to the front by clicking 

it with the Change Position  tool active while holding down SHIFT. 
7. Using the above technique, draw the following bridged polycycles on your own: 

Prismane 

 
Pentaprismane 

 
You can also choose the above structures from the corresponding templates in the Template 
Window dialog box.  For more information on this dialog box, refer to Section  5.5. 

Note The CHAPTER4.SK2 file (Page 6/9) with these three structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

8. On the General toolbar, click Save File , then click New Page . 

ACD/ChemSketch Tutorial 56 



Advanced Structures, SMILES and InChI Notations, and Reaction Schemes 

4.5.4 Creating the Structure of Dodecahedrane ([5]Fullerene-C20) 

 This section is based on the FULLER.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

 

1. On the References toolbar, choose Cyclopentane . 
2. Click in the workspace to place a cyclopentane ring. 
3. Sequentially point to each bond of the ring and click to attach five other rings: 

 

4. Right-click to quickly switch to the Select/Move  tool. 
5. Move by dragging atoms a, c, e, g, i to atoms b, d, f, h, j accordingly as shown in the 

following scheme to merge them: 

 

6. On the Atoms toolbar, click Carbon , and then click directly carbon atoms indicated below 
by arrows to add five methyl groups: 
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7. Connect the adjacent methyl groups with single bonds by dragging from one terminal atom to 
another to obtain the following structure: 

 

8. On the Structure toolbar, click 3D Optimization  to obtain the 3D model of the drawn 
[5]fullerene-C20-Ih structure. 

9. On the Structure toolbar, click 3D Rotation . 
10. Point to any atom or bond on the structure, and drag over the workspace to obtain the 

projection you want. 

 
Note You can choose whether the background bond will be broken or not in the 

structure: 
1. From the Options menu, choose Preferences, and then switch to the 

Structure tab of the dialog box that appears. 
2. In the Bonds Intersections area, select or clear the Enable check box. 

 
You can change the position of intersecting bonds by applying the Bring Bond to 
Front (CTRL+F) or Send Bond to Back (CTRL+K) commands (Tools menu) to 
the selected bond.  You can also bring the background bond to the front by clicking 

it with the Change Position  tool active while holding down SHIFT. 
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11. Using the above technique, draw the following fullerene structures on your own: 

 

[4,6]Fullerene-C24-Oh 

 

[5,6]Fullerene-C32-D3 
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Tip You can also choose the above structures from the corresponding templates in the 
Template Window dialog box.  For more information on this dialog box, refer to 
Section  5.5. 

If you obtain a “Moebius” structure: 

 
instead of a fullerene-type structure, it means than the optimization has converged 
to an unusual value.  To fix the malfunction: 

1. Click Undo  to return to your pre-optimized structure. 

2. Click Clean Structure  or move some of the atoms slightly using the 

Select/Move  tool, and then optimize the structure again. 

12. On the General toolbar, click Save File , then click New Page . 

Note The CHAPTER4.SK2 file (Page 7/9) with these three structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

4.6 Drawing, Labeling, and Mapping Reactions 

This section explains how to draw reactions and complex chemical schemes with manual or 
automatic mapping. 

4.6.1 Drawing a Reaction 

 This section is based on the REACTION.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

In this section, we will draw the following reaction: 

+
 

1. On the References toolbar, click Table of Radicals , and then choose Benzene  
(if you have recently used this template, you can find it on the toolbar). 
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2. Pressing TAB to flip the template’s outline when necessary, draw the following structure by 
clicking in the workspace several times: 

 
Note To draw a fused-ring structure, place the cursor directly over a ring bond as shown, 

and then click. 
3. Press TAB to flip the outline again, and click beside the drawn structure to place a separate 

ring. 
4. Right-click to hide the template outline: 

 

5. On the Structure toolbar, click Draw Normal , and then click the bond of the benzene ring 
to make it triple: 

 
6. Draw the structure of triptycene as described in Section  4.5.2, and place it to the right of the 

other structures: 

  

7. On the Structure toolbar, click Reaction Plus , and then place the plus sign between the 
first and the second structures by clicking: 

+
 

ACD/ChemSketch Tutorial 61 



Advanced Structures, SMILES and InChI Notations, and Reaction Schemes 

8. Click Reaction Arrow , and then either click or drag to place the arrow as well: 

+
 

Note By clicking the lower right triangle of the Reaction Arrow  button you can 
choose from a variety of reaction arrows.  However, some arrows are treated as 
graphical objects and cannot be exported properly. 

9. To move the plus sign or the arrow within the reaction as desired, click Select/Move , 
point to the object, and then drag. 

4.6.2 Labeling a Reaction 

In this section, you will study how to add experimental conditions to a reaction: 

1. On the Structure toolbar, click Reaction Arrow Labeling . 
2. Click the reaction arrow to display the Edit Reaction Conditions dialog box. 
3. In the upper box of the Edit Reaction Conditions dialog box, type 25, and then click 

°C  on the right toolbar of the dialog box. 
4. In the lower box, type benzene: 

  
5. Click OK to close the dialog box.  The reaction now looks like this: 

 
Note The CHAPTER4.SK2 file (Page 8/9) with this reaction can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
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4.6.3 Mapping a Reaction 

This procedure allows you to map a drawn reaction either manually or automatically.  To 
differentiate between the automatically generated and manually inserted atom numbers, select 
different colors for automatic and manual mapping. 
1. From the Options menu, choose Preferences to display the Preferences dialog box. 
2. Switch to the Reaction tab, and then select the red color in the Manual Mapping Color box: 

 
3. Switch to the Structure tab, and then select the blue color in the Auto/Manual Numbering 

Color box. 

 
4. Click OK.  Now, we can get down to mapping as it is. 

5. On the Structure toolbar, click Atom-Atom Map  to display the Map Tools panel and 
enable the mapping mode: 

 
Note The Manual Mapping mode is automatically enabled (the corresponding button is 

active). 
6. Point to the atom in the reactant, and drag to the corresponding atom in the product. 

 
As you release the mouse button, 1 appears on the reaction near the reactant atom and near 
its counterpart on the product denoting manually mapped atoms. 

7. Point to the next atom, and drag again to its counterpart in the product: 

 
As you release the mouse button, 2 appears on the reaction near the reactant atom and near 
its counterpart on the product denoting manually mapped atoms. 
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8. Now, on the Map Tools panel, click Auto Mapping .  As a result, all other atoms are 
automatically assigned to each other: 

 
Note The mapped atoms are only visible when the Map Tools panel is displayed. 

9. On the General toolbar, click Save File , then click New Page . 

4.6.4 Calculating Reaction Data 

1. Using the acquirements (see Section  4.6.1), draw the following reaction: 
O

O

CH3
O

Cl

CH3

OH

N
+ +

acetyl chloride phenol pyridine phenyl acetate
 

1. On the Structure toolbar, click Reaction Calculator , and then click the reaction arrow. 
2. In the Reaction Calculator dialog box that appears, select the Show Total check box: 

 
3. In the row that corresponds to acetyl chloride (C2H3ClO), double-click the Quantity cell (n) to 

select it, type 0.11 (in mol), and then press ENTER. 
4. To calculate the volume, you need to enter the density of the compound.  Double-click the 

corresponding Density cell (d), and then type 1.1 (in g/mL).  After you press ENTER, the 
calculated value in mL appears in the adjacent Volume cell (V). 
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5. Similarly, insert the following values into the corresponding cells of the Components table: for 
phenol (C6H6O)—0.1 mol for quantity (n), for pyridine (C5H5N)—0.11 mol for quantity (n) and 
0.983 g/mL for density (d).  Note that all of the dependent data is calculated automatically. 

6. Double-click the Mass cell (m) corresponding to the phenyl acetate, (C8H8O2) and type 
12.9 (in g). 

7. Press ENTER.  You will see that the yield is calculated and the Based on notation appears 
under Yield in the row corresponding to phenol: 

 
9. Click OK to close the Reaction Calculator dialog box and paste the populated Components 

table to the ChemSketch page: 

 
Note The CHAPTER4.SK2 file (Page 9/9) with the reaction and Components table can 

be found in the ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

10. On the General toolbar, click Save File , then click Close Document . 
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5. Advanced Drawing: Templates 

5.1 Objectives 

This chapter brings you yet another step closer to advanced drawing expertise once you have 
mastered the powerful Template feature.  You will learn: 

• Some ways of template usage; 
• How to apply the Instant Template tool to drawing the structures containing repetitive 

fragments; 
• More ways of using the Table of Radicals; 
• How to use the Template Window dialog box for drawing DNA structures and complex 

biomolecular structures; and 
• How to create your own templates. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Structure mode of ACD/ChemSketch. 

5.2 Overview 

ACD/ChemSketch includes the following three template tools for drawing structures: 

• Table of Radicals  

• Instant Template  

• Template Window  

While the binding point of any template of the Table of Radicals tool is fixed (invariable), the 
Template Window and Instant Template ones allow you to specify any atom or bond to be the 
binding point by clicking it directly.  However, no matter what the source of template is, the 
principles of joining are the same.  There are several ways of joining the template to a drawn 
structure: 

• By fusing the bonds of the structure and template: point to the bond so that the 
corresponding bonds of the structure and the template’s outline are fused, and then click. 

• By attaching the template to the structure: point to the corresponding atom on the 
structure so that the connecting bond appears, and then click. 

• By drawing a spiro-connection between the template and the structure: point to the 
atom you want to be the binding point while holding down SHIFT, and then click. 

Note You can flip the template’s outline before fixing it by sequential pressing TAB. 
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5.3 Table of Radicals 

The Table of Radicals is a set of chemical radicals for structure drawing.  Their names and, in 
some cases, abbreviations will help you to quickly translate “chemistry shorthand” into a 
meaningful structure. 

5.3.1 Creating Structure of Fluorescamine 

 This section is based on the FLUOR.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

We will draw the following structure of 4'-phenyl-3H,3'H-spiro[2-benzofuran-1,2'-furan]-3,3'-dione 
using templates taken from the Table of Radicals: 

O

O

O O  
1. Being in the new blank ACD/ChemSketch document, on the References toolbar, click Table 

of Radicals , and choose Cyclopentane  (if you have recently used this template, 
you can find it on the toolbar). 

2. Click within the ChemSketch workspace to paste the cyclopentane ring. 
3. Click the carbon atom of the ring while holding down SHIFT to obtain the spiro-connection 

with the second cyclopentane ring: 

 

4. On the References toolbar, click Table of Radicals , and choose Benzene  (if you 
have recently used this template, you can find it on the toolbar). 

5. First click the indicated bond to fuse the benzene ring, and then click the indicated atom to 
connect the phenyl radical: 
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6. On the Atoms toolbar, click Oxygen  (note that the Draw Normal tool  is automatically 
enabled), and then click the indicated carbon atoms to replace them with oxygen atoms: 

 

7. Right-click to quickly switch to the Draw Continuous  tool, and then double-click the 
indicated carbon atoms to attach the OH groups to them: 

 
8. Click the indicated single bonds to replace them with double ones: 

 
Note The CHAPTER5.SK2 file (Page 1/4) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9. On the General toolbar, click Save File , in the Save Document As dialog box that 
appears, specify the name and location of the file to which the work should be placed, and 
click Save. 

10. On the General toolbar, click New Page . 
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5.4 Instant Template Tool 

You might want to copy a molecular fragment that is not in the Table of Radicals.  You can think 

of the Instant Template tool  as a “paste” command.  It is better than simple paste, however, 
because you can specify the junction point. 

5.4.1 Creating Structure of Cyclic Oligomer 

 This section is based on the OLIGOMER.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

We will draw the following cyclic oligomer structure using templates taken from the Table of 
Radicals: 

 

1. On the References toolbar, choose Benzene , and click in the upper middle part of the 
workspace to place a benzene ring. 

2. On the References toolbar, click Table of Radicals , choose Ethynyl , and then 
click the indicated atom to attach it to the ring: 

 

3. On the Structure toolbar, click Instant Template , and then click the indicated carbon 
atom of the triple bond to create an instant template of the drawn fragment: 
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4. Click the indicated carbon atom to attach the template to it: 

 

5. Click Instant Template  again, and click the indicated carbon atom of the triple bond to 
create a template of the new fragment: 

 
6. Click the indicated carbon atoms of benzene rings to attach the template as shown: 

 

7. On the Structure toolbar, click Draw Normal , and click the indicated atom to complete 
the ring: 

 
Note The CHAPTER5.SK2 file (Page 2/4) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

8. On the General toolbar, click Save File , then click New Page . 
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5.5 Template Window 

The Template Window feature is the most sophisticated of the three template facilities in 
ACD/ChemSketch because it allows you to organize and store structures or drawings that you 
might want to copy later. 

 A brief tour of available ACD/ChemSketch Templates is given in the 
TEMPLATE_W.EXE movie which can be found in the \\MOVIES\CHEMSK folder. 

5.5.1 Creating Fragment of DNA 

 This section is based on the DNA_ST.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

Let’s draw the following fragment of single-stranded DNA molecule: 

 

5.5.1.1 Drawing Chain of Deoxyriboso-5-phosphate Fragments 

1. On the General toolbar, click Open Template Window . 

2. On the  tab of the Template Window dialog box, choose a structure of 2-
deoxyriboso-5-phosphate (chain form) by clicking the hydroxyl group indicated below to set 
the point of template’s junction: 

 
3. Click within the workspace to paste the chosen template. 
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4. Holding down SHIFT, point to the indicated atom, and click to attach the next 2-deoxyriboso-5-
phosphate fragment: 

  

5. Click Select/Rotate/Resize . 

6. Drag to select the indicated part of structure, and then drag the action center  onto the 
indicated oxygen atom: 

.  
7. Holding down SHIFT, point to the fragment to make it selected (note that the mouse pointer is 

changed to ), and drag the selected part of structure clockwise to rotate it by 90o: 
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As you release the mouse button, you will see the results of the fragment’s rotation: 

 
8. Click out of the structure to cancel selection of the fragment. 

5.5.1.2 Adding Bases 

1. Open the Template Window dialog box. 

2. On the  tab, choose uracil by clicking the indicated nitrogen atom so that 
this will serve as the attachment point: 

 
3. Point to the atom indicated below, and click while holding down SHIFT: 

 
Tip You can flip the template’s outline before fixing it by pressing TAB. 
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4. Repeat steps 1 and 2 to add the adenine base to the structure: 

 
Note The CHAPTER5.SK2 file (Page 3/4) with this structure can be found in the 

ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

5. Now, try to draw your own DNA or RNA fragments of any other length. 

6. On the General toolbar, click Save File , then click New Page . 

5.6 Drawing Complex Structures of Biomolecules 

Here are some examples for creating complex structures of biomolecules using different 
ACD/ChemSketch tools. 

5.6.1 Creating Structure of Beta-Maltose 

 This section is based on the MALTOSE.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

Let’s draw the following structure of β-Maltose using templates taken from the Template Window: 

 
1. Open the Template Window dialog box, switch to the  tab, and 

ensure that you are viewing the Haworth formulae page.  If not, select it by choosing the name 
from the corresponding list at the top of the dialog box: 

 

2. Click the structure of α-D-Glucopyranose to select it, and click within the workspace to paste 
it. 

ACD/ChemSketch Tutorial 74 



Advanced Drawing: Templates 

3. Repeat steps 1–2, but this time select the  tab, and choose structure 
of β-D-Glucopyranose. 

Note If the Sugars: beta-D-Pyr tab is absent at the left part of the dialog box, choose its 
name from the leftmost drop-down list at the top of the dialog box. 

4. Click in the ChemSketch window to place it to the right of the first structure: 

  

5. On the Atoms toolbar, click Carbon . 

6. Click the indicated atom in the α-D-Glucopyranose structure to replace it with a CH3 group, 
and then drag from the methyl group to the right while holding down SHIFT to draw the new 
bond exactly at the right angle: 

 
7. Repeat the previous step for the β-D-Glucopyranose structure to obtain the following 

structure: 

 

8. On the Atoms toolbar, click Oxygen , and then click the methyl group in the β-D-
Glucopyranose structure to replace it with the hydroxyl one: 

 

9. On the Structure toolbar, click Select/Move .  Click in the workspace near to, but not 
touching, the left α-D-structure to select it. 

ACD/ChemSketch Tutorial 75 



Advanced Drawing: Templates 

10. Point to any atom or bond of the selected structure, and drag it to the right until the 
corresponding OH and CH3 groups overlap each other as shown below, then release the 
mouse button and click outside the selection: 

 
11. From the Tools menu, choose Remove Explicit Hydrogens to hide single hydrogens in the 

selected structure. 
12. Through the drawn CH2 groups in the oxygen bridge are hidden, they are actually present in 

the structure.  If the chemical meaning is important for your task (for example, in calculating 
the formula weight), you can remove these atoms in one of the following ways: 

a Click Pseudo Atom  on the Atoms toolbar.  If this button is missing, click the 

white bottom right triangle of the displayed Radical Label  button, and then, on a 

set of tools that appears, click . 
b Point to the atom group you want to remove, and then click.  The CH2 group will 

disappear: 

. 

–OR– 

a With the Select/Move  tool active, double-click the hidden atom group.  The 
Properties panel will appear. 

b Click Atom Symbol , and then, from the adjacent Value list, choose Empty. 
c Click Apply, and then close the panel. 

13. Using the technique described above, try to draw the following structure on your own (note 
that you need to drag at an acute angle in the step 6): 

 

β-Cellobiose 

Note The CHAPTER5.SK2 file (Page 4/4) with these two structures can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

14. On the General toolbar, click Save File , then click Close Document . 
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5.7 Defining a User Template 

It is very easy to create a template out of a ChemSketch file.  We are offering free templates 
included with the ACD/ChemSketch installation package (the \\TEMPLATE folder). 

Note This is a templates exchange page, so if you have a set of structures or drawings 
that you think might be helpful to the ACD/ChemSketch community, consider 
sharing it! 

To designate the structures you have drawn as a user template: 
1. From the Templates menu, choose Save User Template. 
2. If the ChemSketch document has not yet been saved, the Save Document As dialog box 

appears where you can specify the name and location of the file, e.g., 
C:\ACD\TEMPLATE\MALTOSE.SK2, and click Save. 

3. In the Save User Template dialog box, type the name for your template, such as Maltose: 

 
4. Click OK. 

Note You can enter any name for your template (e.g., for the document B_D_FUR.SK2 
the following name—Sugars: beta-D-Furanose—would be the most appropriate). 

Once your document is saved as a user template, the name you typed is automatically added to 
the list of templates in the Template Window dialog box (for more information, refer to 
Section  5.5). 
5. Close the active ACD/ChemSketch document. 

5.7.1 The User Template Window Organizer 

The User Template Window Organizer is a very convenient way for managing template files: both 
of those included with the software package, and those that you decide to create.  It will just take 
you a moment to add your ACD/ChemSketch document to the list of templates even if the 
document is closed: 

1. From the Templates menu, choose Template Organizer to display the User Template 

Window Organizer dialog box, and click New . 
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2. In the Create User Template dialog box, specify the name and location of the needed 
document, assign a template name to it, and click OK. 

Note that the only difference between the template file and a regular .SK2 file is the fact that the 
template file is assigned as a template in the User Template Window Organizer.  By saving files 
this way, there are several advantages: 

• Your .SK2 files scattered over different folders and disks will be gathered in one place (the 
User Template Window Organizer). 

• You can assign a name to the template that is more descriptive than the real file name is.  
This will better reflect the contents of the document and allow you to quickly find the 
document you need. 

• You can quickly find a document by previewing its contents in the Preview area of the 
Template Window dialog box. 

• You can quickly open in the workspace a selected document from the list by clicking Open 

Document  in the User Template Window Organizer dialog box. 

• Up to 5 user templates can be accessed through the Template Window. 

You can perform the following actions with a user template: 

⇒ Modify a template.  To do this, from the Templates list of the User Template Window 

Organizer, choose the needed template, and click Open Document .  
Make changes as needed, and then save. 

⇒ Copy and paste any structure/image of a template to the workspace (either Structure 
or Draw mode) without opening the whole document.  To do this, choose your template in 
the Templates list of the Template Window, and click the item to select it and place to the 
workspace. 

5.7.2 The TEMPLATE.CFG File 

The key to management of the templates in ACD/ChemSketch is the TEMPLATE.CFG file.  This 
file lets ACD/ChemSketch know that an .SK2 file is a template file rather than simply a user file.  
It can be opened and read with any text editor, although you will likely never need to do so.  The 
Template Window accesses TEMPLATE.CFG to obtain information on what files to display as 
templates.  If an .SK2 file is not shown in the Template Window, it will be added to 
TEMPLATE.CFG when you open .SK2 as a regular ACD/ChemSketch file and select the 
command to save as a user template (as described above). 

If TEMPLATE.CFG is moved or lost, the Template Window will not display any templates.  If the 
TEMPLATE.CFG file can be found (for example, by Windows Explorer or the system’s Find File 
utility), it can be restored either to the default directory or to the user’s private folder.  If it cannot 
be found, it can be retrieved by reinstalling ACD/ChemSketch or by adding each template as 
described above. 
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6. Calculating Macroscopic Properties 

6.1 Overview 

In addition to the drawing capabilities, ACD/ChemSketch offers predictions of numerous 
properties for your compounds. 

In this chapter, the simple means to calculate these properties is described. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Structure mode of ACD/ChemSketch. 

6.2 Calculating Physicochemical Properties for a Structure 

6.2.1 Calculating Properties and Pasting Results to ChemSketch Page 

To determine all (or some) of the available physicochemical properties for entire structure, follow 
the steps: 
1. Draw a structure—for example, benzoic acid: 

O

OH

 

ACD/ChemSketch Tutorial 79 



Calculating Macroscopic Properties 

2. On the Tools menu, point to Calculate, and then choose All Properties (or one of the 
available properties).  As a result, the calculated property is displayed in the Calculation 
Results dialog box.  For example, choosing All Properties for benzoic acid will show the 
following dialog box: 

 

3. Click Copy to Editor  to paste the results in the workspace.  As the text is 
inserted, you are switched to the Draw mode where you can edit the text if necessary. 

Note On the Tools menu, point to Calculate, and then choose Select Properties to 
Calculate to define a set of properties to be calculated.  In the dialog box that 
appears, mark the properties and click OK.  If you now choose Selected 
Properties, only the selected properties will be calculated. 

4. Switch back to the Structure mode and save the document to CALC_PROP.SK2. 

Note The CHAPTER6.SK2 file (Page 1/2) with the structure and calculation results can 
be found in the ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
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6.2.2 Displaying Properties Automatically on Status Bar 

It is also possible to view the physicochemical properties for the structure selected in the 
workspace directly on the status bar: 

• On the status bar, click Properties , and repeatedly choose the desired 
properties from the menu by placing ticks next to the corresponding properties’ names: 

 
Note If no structure is selected in the workspace, the properties are calculated for all the 

structures displayed; if there are no structures drawn, no properties will be 
displayed. 

By default, the display of the properties is set to formula weight.  In the example shown, the molar 
refractivity, MR20: 33.18±0.3 cm3, and dielectric constant, ε20, have been specified. 
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6.3 Calculating Monoisotopic Mass for a Fragment 
(MassSpec Scissors) 

In this section, we’ll calculate monoisotopic mass for a structural fragment: 

1. On the General toolbar, click New Page  to add a new blank page in current 
ACD/ChemSketch document. 

2. Draw a structure—for example, the following acid: 

NH

O

N

O

OH

O OCH3

CH3

H

 
3. Select a bond to cut (it should be a non-cyclic one): 

 
4. From the Tools menu, choose MassSpec Scissors (or click the corresponding MassSpec 

Scissors  button on the Structure toolbar).  This will display monoisotopic mass 
underneath BOTH of the structural fragments in the workspace: 

NH

O

N

O

OH

O OCH3

CH3

H

C10H13

133.1017 Da
C6H9N2O5

189.0511 Da  



Calculating Macroscopic Properties 

You can change the style of the separating line: in the Draw mode, double click the line, and 
then, on the Objects Panel dialog box, change the style as desired. 
 
You can also see the nominal and average masses on the status bar using the 
Properties  tool (refer to Section  6.2.2). 

Note The CHAPTER6.SK2 file (Page 2/2) with this structure can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

5. On the General toolbar, click Save File , then click Close Document . 
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7. Special Function Keys 

7.1 Objectives 

ACD/ChemSketch is an extremely versatile molecular structure editor.  For this reason, several 
ACD/Labs modules are accessible as buttons from the ACD/ChemSketch interface. 

This chapter describes three special modules, which can also be accessed from the 
ACD/ChemSketch interface: ACD/Tautomers and ACD/Name Freeware Add-On are included 
with both commercial and freeware versions of ACD/ChemSketch; ACD/Dictionary is also 
available but only with the commercial software. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Structure mode of ACD/ChemSketch. 

7.2 ACD/Tautomers 

For certain compounds, there is a mixture of two or more structurally distinct forms which exist in 
rapid equilibrium in solution.  In most cases, tautomers result from a form of proton transfer.  
ACD/Tautomers is designed to generate the most reasonable tautomeric forms of drawn organic 
structures.  It is available as the Check Tautomeric Form command through the Tools menu or 

as the Check for Tautomeric Forms  button on the Structure toolbar. 

The possibility of the alternative tautomeric forms should always be carefully considered, if the 
drawn organic structure contains two or more double or triple bonds conjugated with or attached 
to oxygen, nitrogen, sulfur, or other heteroatoms.  The current ACD/Tautomers algorithm 
provides only the suggested tautomeric forms, but not necessarily the correct forms.  Consult 
other sources of information to make a final decision. 

The ACD/Tautomers algorithm does not proceed with the following classes of chemical 
structures: 

• Structures containing metal atoms; 
• Structures containing charged atoms, other than the non-ionic derivatives of IV-valent 

nitrogen (+) bonded to oxygen (–); 
• Structures containing elements in their non-typical valence; 
• Structures with coordinating bonds; and 
• Structures containing more than 255 atoms. 
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Now we are going to try this option on the illustrative example: 
1. Using the technique described in the previous chapters, draw the following structure: 

N
N
H

NO

O  
Note The CHAPTER7.SK2 file with this structure can be found in the ACD/Labs example 

folder, \\ACD\EXAMPLES\CHEMSK\. 
2. Select the structure, and then, on the Structure toolbar, click Check for Tautomeric 

Forms .  The program starts generating and checking tautomeric forms of the drawn 
structure, and when the process is finished, the following dialog box is displayed: 

 
3. Using the Next >> or << Prev buttons, select the second tautomeric form (4-(2H-1,2,3-triazol-

4-yl)-5,6-dihydropentalene-1,3(2H,4H)-dione). 

4. Click Replace  to change the drawn structure for the currently selected one. 
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7.2.1 Examples 

Here are a few “classic” types of tautomerism which you can try out with the Check Tautomeric 
Forms feature described above. 

Tautomerism Example 
Keto-Enol  CH3

O

CH3

CH3

CH3

OH

CH3

CH3  
Phenol-keto OHO

 
Heterocyclic ring 

N
H

O

N

OH

 
Nitro-acid form 

CH3

CH3

N
+

O
-

OCH3

CH3

N
+

O
-

OH

 
Nitroso-oxime 

CH3
N

O

CH3

CH3
N

OH

CH3  
Imine-Enamine 

CH3

CH3

CH3

N
CH3

CH3

CH3

CH3

NH
CH3

 

7.2.2 Mistakes in Chemical Literature 

Chemical structures are often drawn as one tautomeric form, and other existing forms are simply 
ignored.  Unfortunately, you can never be sure that a particular compound will be drawn the 
same way by another chemist.  Therefore, the consideration of possible tautomeric forms is very 
important for structure search, data prediction, and interpretation. 

All of the structures below have been taken from respected publications.  Many have incorrect or 
ambiguous assignment of tautomeric forms under the experimental conditions described.  With 
ACD/Tautomers, you no longer run the risk of overlooking a common tautomeric form for the 
compound you are trying to publish, interpret observed data for, or run ACD/Labs predictions on. 
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Questionable Structures from Various Publications 

N

NH

N

N
H

S

NH2  
N

N
H

N

N

SH

 

N

N N
H

N

OH

 
Thioguanine (antineoplastic) 

12 possible forms 
6-Mercaptopurine 
(antineoplastic) 
6 possible forms 

Allopurinol (antiurolithic) 
6 possible forms 

OH

OH

OH

N

N

N

N

NH2

 
N

O

OH

Cl  
N

O

O

NH2

 
Leucopterin 

>10 possible forms 
Chlorzoxazone 

(skeletal muscle relaxant) 
2 possible forms 

Pemoline (CNS stimulant) 
3 possible forms 

N

N
N

NHNH2

SH

NH2

 

N

N
SH

CH3

 
N

N
N
H

NH2 

Purpald 
4 possible forms 

Methimazole (antihyperthyroid) 
2 possible forms 

Amitrole (herbicide) 
5 possible forms 

N

N
H

O

NH2

F

 

N
+OH

O
-

CH3  

N

N

SH

I

OH

 

Flucytosine (antifungal) 
6 possible forms 

Ciclopirox (antifungal) 
2 possible forms 

Iodothiouracil (thyroid inhibitor) 
6 possible forms 

N

OOH

OH OH

 

N

N
N

OH

S

NH2

CH3

 

N
NHNH

NH

Cl

Cl OH  

Citrazinic acid 
2 possible forms 

Methisazone (antiviral) 
2 possible forms 

Guanoxabenz 
(antihypertensive) 
3 possible forms 
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N
NNHNH

NH

NH

NH2

NH2

CH3

 

S
N

NHS

O O

O NOH

CH3

 

OH O OH

 

Mitoguazone (antineoplastic) Tenoxicam 
(anti-inflammatory, analgesic) 

Anthralin (antipsoriatic) 
>10 possible forms 2 possible forms 

4 possible forms 

 

7.3 ACD/Dictionary 

For Commercial Version only 

ACD/Dictionary is an add-in module that is supplied with all of the commercial copies of 
ACD/ChemSketch.  It is immensely useful at finding “chemicals” by their common names. 

ACD/Dictionary finds chemical structures according to their chemical name.  It contains more 
than 165,000 systematic and non-systematic names and their corresponding molecular 
structures.  The dictionary is searchable by both the full chemical name and name fragments. 

ACD/Dictionary is covered in full in the ACD/Dictionary User’s Guide, located in the ACD/Labs 
documentation folder, \\DOCS\DICT.PDF. 

Note If you have purchased ACD/ChemSketch, but do not see the Dictionary 

button  on the References toolbar when you are in the Structure mode, 
please verify that you have correctly entered TWO registration numbers at the time 
of installation by checking them in the List of Registration Keys of the ACD/Labs 
Registration dialog box (\\REGISTER.EXE): the one for ACD/ChemSketch (Main), 
and another for the ACD/Dictionary (Add-in). 

7.4 ACD/Name Freeware Add-on 

Within the ACD/ChemSketch, it is possible to use ACD/Name Freeware Add-On.  This extra 

functionality is available via either the Generate Name for Structure button  on the General 
toolbar or the Generate>Name for Structure command from the Tools menu. 
This tool is easy to use, so let’s try naming some example structures to demonstrate this: 
1. Using ChemSketch tools, draw the following structure: 

O

OH

N
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2. If there is more than one structure drawn in the workspace, select only the above structure. 

Note If no specific structure is selected, the program will generate chemical names for 
all of the structures found in the workspace, considering them as a mixture of 
compounds in a corresponding proportion. 

3. On the General toolbar, click Generate Name for Structure .  The name appears 
selected below the drawn structure: 

 
Note The name generation preferences specified either in ACD/Name or in any 

ACD/Labs Database program will affect the result of the name generation in 
ACD/ChemSketch. 

4. Drag the name string up to place it above the structure. 

5. On the Atoms toolbar, click Chlorine , and then click once near the structure to draw HCl. 

6. Select both the structures, and click Generate Name for Structure  again.  This time the 
name for a mixture appears: 

 
Note The CHAPTER7.SK2 file with this structure can be found in the ACD/Labs example 

folder, \\ACD\EXAMPLES\CHEMSK\. 
7. Click somewhere in the workspace to cancel selection of the name string. 
8. Save your work as the EXAMPLE4_1.SK2 file. 

7.4.1 Limitations of ACD/Name Freeware 

ACD/Name Freeware has the following limitations: 

• Structures to be named can contain no more than 50 atoms, including hydrogen. 
• Structures can only contain the elements H, C, N, P, O, S, F, Cl, Br, I, Li, Na, and K in their 

common valences. 
• Structures can contain no more than 3 cycles. 
• The freeware version does not allow you to change the naming preferences.  It uses the 

preferences that correspond to the most preferable IUPAC names. 

Note For more information on ACD/Name, visit our Web site at 
http://www.acdlabs.com/products/draw_nom/nom/name/ 
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8. Searching for Structures—
Commercial Version Only! 

8.1 Objectives 

In this section, you will obtain some basic skills on how to perform searches for structures from 
ACD/ChemSketch environment. 

In this section, you will learn how to: 
• Perform searches for structure in the files on your computer; 
• Customize the search options to suit your requirements; 
• Set a mask for files to be searched through; 
• View the search results. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Structure mode of ACD/ChemSketch. 

8.2 Searching for Structure 

The Search for Structure tool allows you to search for drawn chemical structure(s) in a variety of 
files without opening them.  As the structure is found, it can be viewed and placed either into the 
ChemSketch window or to the other applications. 

8.2.1 Specifying Files to Search Through 

You can search for specific structures through the files of currently available formats: 

1. On the General toolbar, click New Page . 
2. Draw a structure of toluene (or find it in ACD/Dictionary): 

CH3
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3. On the General toolbar, click Search for Structure  to display the ACD/Search for 
Structure dialog box.  Note that the drawn structure is placed to the Search Pattern box: 

 
4. In the Look In box, select the folders and/or files to search through.  For our example, find the 

ACD/Labs example folder and select it with all of the subfolders: 

 

5. To set the formats of the files to search through, click Browse  below the Look In box to 
display the Look Through Files dialog box. 
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6. Click Unselect All  to clear all of the check boxes, and then select the 
ACD/ChemSketch Document, MDL Molfiles, and Microsoft Word Document check boxes: 

 
Tip You can narrow the search by defining the file mask for any of the selected formats: 

highlight the format name in the list, then click Change Mask , and 
type a file mask in the dialog box that appears. 

7. Click OK to apply your changes: 

 

ACD/ChemSketch Tutorial 92 



Searching for Structures 

8. In the ACD/Search for Structure dialog box, click Options  to display the 
Search Options dialog box: 

 
9. On the General tab, under Search Type, choose SubStructure Search, and then, in the 

Search Within File area, choose All Occurrences. 
10. Switch to the Open tab, and define the application to be used for opening the corresponding 

files—for this example, leave the default Open in ChemSketch option selected. 
11. Click OK. 
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8.2.2 Considering Search Results 

Now, we can perform search for the desired substructure: 

1. In the ACD/Search for Structure dialog box, click Search .  As the search 

proceeds (note that during this the Search  tool changes to the Stop 

 one), pathnames of the files where the query structure is found are displayed in 
the Search Result area of the dialog box. 

2. Click the desired name in the list of found files to view the structure(s) found by your query in 
the Preview area: 
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If, there is a Microsoft Word Document file (.DOC) among the search results, clicking its name in 
the list will display the OLE object that contains the query structure.  For example: 

 

To open the found file, in the Preview area, click Open  or double-click the file name in the 
Search Results list. 

To save the search results, as well as the query structure and folder settings, into an 

ACD/Search for Structure file (.SSF), click Save .  Thereafter, you can open this file 

by clicking Load . 

Note If a found .SK2 file is opened in ACD/ChemSketch, a new page is created, in other 
cases, the file opens as usual. 
As the opening takes place, you do not leave the Search for Structure dialog box. 

3. On the General toolbar, click Save File , then click Close Document . 
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9. Creating Graphical Objects 

9.1 Objectives 

This chapter will familiarize you with the creation of graphical objects in the Draw mode of 
ACD/ChemSketch.  You will learn how to use the Draw mode tools for creating the following 
objects: 

• A diagram of the energy of reaction; 
• Various types of orbitals; 
• Vacuum distillation apparatus; 
• A two-chain DNA strand; 
• Lipids and micelles; 
• Multipage layout posters. 

You will also learn how to output PDF files, a task that can be done for graphical or chemical 
objects. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Draw mode of ACD/ChemSketch. 

9.2 Drawing the Energy of Reaction Diagram 

 This section is based on the DIAGRAM.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

We are going to draw the following diagram: 
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9.2.1 Drawing a Curve 

With the Polyline tool, you can create a curve (Bézier curve) by adding a node (anchor point) 
where a curve changes direction, and dragging the direction lines that shape the curve.  The 
length and slope of the direction lines determine the shape of the curve. 

This section describes how to draw a curve: 

1. On the General toolbar, click  to switch to the Draw mode of ACD/ChemSketch. 
2. From the File menu, choose New to start a new document. 

3. On the Drawing toolbar, click Polyline . 
4. Position the Polyline tool where you want the curve to begin, and drag horizontally to the right 

from the starting node of the curve to extend the direction line (as shown step-by-step in the 
picture below). 

Tip In general, extend the direction line about one third of the distance to the next node 
you plan to place.  By changing the length of the lines you can modify the curve 
segment.  You can adjust one or both sides of the direction line later (for more 
information, refer to the following section). 

5. Release the mouse button. 
6. Move the mouse up to the point where you want the first curve segment to end. 
7. Drag horizontally to the right to extend the direction line. 

Note To create a C-shaped curve, drag in a direction opposite to the previous direction 
line. 
To create an S-shaped curve, drag in the same direction as the previous direction 
line. 

8. Release the mouse button. 
9. Move the mouse down to the point where you want the second curve segment to end: 

horizontally

horizontally

 
10. Repeat the above steps to draw the next two segments of the curve. 
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11. Right-click to finish drawing the curve. 

Tip When drawing with the Polyline  tool, it is helpful to remember that a “click” will 
create an endpoint, a cusp, or an angle, and a “drag” will create a curve: 

    

9.2.2 Modifying a Curve 

The first time you draw a curve with the Polyline  tool, you might have some trouble getting 
the curve to turn out the way you want.  For example, the first attempt might produce something 
like this: 

 
1. On the Editing toolbar, click Select/Move/Resize , and then click the curve to select it. 

2. On the Editing toolbar, click Edit Nodes .  This will show all of the nodes on the curve that 
can be modified: 

 
3. Click the required node to select the it and view corresponding direction lines: 

 
4. Drag the lines, then select and modify the other nodes until the curve looks as you like. 

Tip When using the Edit Nodes  tool, you can manipulate nodes using the buttons on 
the Node toolbar that appears.  For example, you can select several nodes by clicking 
on them when holding down SHIFT, and then align them by choosing the 
corresponding button on the toolbar. 

9.2.3 Drawing the X and Y axes 

To accomplish drawing of a reaction diagram, the axes are required. 

1. On the Drawing toolbar, click the Arrow  tool. 
2. From the Tools menu, choose Arrow Style Panel to display the Arrow panel. 
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3. From the drop-down list, choose the one-way arrow: 

 
4. Close the panel. 
5. From the Options menu, select Snap on Grid and/or Show Grid to make your drawing 

easier. 
6. Position the mouse pointer at the origin of coordinates, and drag the mouse up vertically to 

draw the Y-axis. 
7. Position the mouse pointer at the origin of coordinates, and drag the mouse horizontally to the 

right to draw the X-axis: 

 

8. Add the Energy and Reaction Coordinate inscriptions using the Text  and Rotate 90°  
tools. 

Note The CHAPTER9.SK2 file (Page 1/6) with this diagram can be found in the 
ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9. From the Options menu, deselect Snap on Grid and/or Show Grid. 

10. On the General toolbar, click New Page . 
11. Save your work as the EXAMPLE5_1.SK2 file. 
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9.3 Drawing Different Kinds of Orbitals 

This section explains how to draw three kinds of orbitals: p-orbital, d-orbital, and pi-orbital. 

9.3.1 Drawing a p-Orbital 

We are going to draw the following p–orbital: 

 

1. On the Drawing toolbar, click Polygon . 
2. Drag horizontally to the right from the starting point to extend the direction line. 
3. Release the mouse button. 
4. Move the mouse down to draw the body of the half-orbital. 
5. Click to fix the half-orbital. 
6. Right-click to finish drawing the half-orbital, and then right-click again to quickly switch to the 

Select/Move/Resize  tool: 

 

Note If the shape of the curve is not what you want, use the Edit Nodes  tool (refer 
to Section  9.2.2). 

7. Point to the selected half-orbital, and drag it down holding down CTRL to make a copy. 

8. On the Editing toolbar, click Flip Top to Bottom  to flip the lower half-orbital. 
9. Put the half-orbitals together by moving them. 

Tip To arrange the orbital segments more precisely, make sure that the Snap on Grid is 
not selected on the Options menu. 
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10. Click the gray color on the Color palette at the bottom of the window to change the fill color of 
the orbital segment: 

 
Tip To quickly center the orbital segments, select them both, and click Center 

Horizontally . 

11. Select both the segments of the orbital, and then, on the Editing toolbar, click Group .  
Now you can manipulate the segments as a single object, e.g., rotate it using the 

Select/Move/Rotate  tool. 

Tip You can also choose the orbital template (either large or small) from the set of orbitals 
available in the Template Window dialog box. 

9.3.2 Drawing a d-Orbital 

In this section, we will draw the following d–orbital: 

 

1. Select the Polygon  tool again. 

Tip From the Options menu, choose Snap on Grid before drawing to ease the drawing 
of the symmetrical orbital. 

2. Drag horizontally to the right from the starting point of the orbital to extend the direction line. 
3. Release the mouse button. 
4. Move the mouse down to draw the body of the half-orbital. 
5. Drag horizontally to the right to extend the direction lines.  Note that to make the two 

segments of the half-orbital identical, make the lengths of the direction lines equal. 
6. Release the mouse button. 
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7. Right-click to finish drawing the half-orbital, and then right-click again to switch to the 

Select/Move/Resize  tool: 

 
8. With the half-orbital selected and holding down CTRL, drag to make a copy of it. 

9. On the Editing toolbar, click Rotate 90°  to rotate the copy of the half-orbital. 
10. Drag the copy as shown below in the picture. 
11. Click the gray color on the Color palette at the bottom of the window to change the color of the 

orbital segment: 

 
Tip To quickly center the half-orbitals, select them both, and click the Center 

Horizontally  button. 

12. Select both the segments of the orbital, and click Group  on the Editing toolbar.  Now you 
can manipulate the segments as a single object. 

13. On the Editing toolbar, click Select/Move/Rotate  tool, and then rotate the selected 
drawing by 45 degrees while holding down SHIFT. 

9.3.3 Drawing a pi–Orbital 

We will draw the following pi–orbital: 

 

1. On the Drawing toolbar, click Ellipse , and drag in the workspace to draw an ellipse. 
2. From the Object menu, choose Convert to Polyline. 

3. On the Editing toolbar, click Edit Nodes . 
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4. Drag the lowest node up: 

 

5. Right-click to switch to the Select/Move/Resize  tool, then, holding down CTRL, drag 
down the selected half-orbital to make a copy of it. 

6. Click Flip Top to Bottom  to flip the lower half-orbital, and then move it to an appropriate 
position. 

7. Click the gray color on the Color palette at the bottom of the window to change the color of the 
orbital segment: 

 

Tip To quickly center the orbitals, select them both, and click Center Horizontally . 

8. Select both the segments of the orbital, and click Group  on the Editing toolbar.  Now you 
can manipulate them as a single object. 

Note The CHAPTER9.SK2 file (Page 2/6) with the orbitals of three different kinds 
represented in this chapter can be found in the ACD/Labs example folder, 
\\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9. On the General toolbar, click New Page . 
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9.4 Drawing Vacuum Distillation Apparatus 

 This section is based on the APPARAT.EXE movie which can be found in the 
\\MOVIES\CHEMSK\ folder. 

We are going to draw the following apparatus: 

 
1. From the File menu, choose Page Setup, and then, on the Size&Orient. tab of the dialog box 

that appears, select Landscape.  Click OK to close the dialog box. 
2. On the General toolbar, in the Zoom box, set the zoom value to 50%. 

Tip You can also choose the Show Grid and Snap On Grid commands from the 
Options menu to activate the grid-snapping mode and facilitate the process of your 
apparatus assemblying. 

3. Click Template Window  to display the corresponding dialog box, and then, from the 
list of templates, choose Lab Kit. 

4. Click the round-bottom flask (refer to the scheme below). 
5. Click in the workspace to add the selected template. 
6. Open the Template Window dialog box.  Select the three-way adapter (Vigreux distillation 

column with connecting adapter).  Connect it to the flask by clicking. 
7. From the Template Window dialog box, choose the thermometer, and connect it by clicking 

as shown below. 
8. From the Template Window dialog box, choose the Liebig condenser and place it on the 

workspace near the apparatus by clicking.  Right-click to hide the template’s outline and 

switch to the Select/Move/Resize  tool. 
9. Click any selection handle (black squares surrounding the distillation column) to quickly switch 

to the Select/Move/Rotate  tool.  Rotate the selected object about 73° counter-clockwise 
by dragging any selection handle.  The informative cursor will show you the angle of rotation 
(if the corresponding Informative Cursor option has been selected on General tab of the 
Preferences dialog box (Options > Preferences command): 
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10. Drag the column, and attach it to the apparatus. 
11. From the Template Window dialog box, choose the vacuum-distilling adapter, and attach it to 

the apparatus. 

12. With the adapter still selected, click Send to Back  to send the selection to the 
background.  This will prevent overlaying of the Liebig condenser’s outlet by the adapter 
template in the drawing. 

13. Complete the drawing by connecting the receiving flask (round-bottom flask) taken from the 
list of templates: 

 
Tip You can also find the complete template of the vacuum distillation apparatus on the 

second page of the Lab Kit list of templates. 
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9.4.1 Annotating a Diagram 

ACD/ChemSketch enables you to draw many elegant and detailed set-ups of your glassware 
apparatus.  The Lab Kit template includes burettes, beakers, hot plates, Bunsen burners, etc. so 
that you will be able to draw an experiment from start to finish. 

Let's say that you are preparing the diagram for an instruction manual in an undergraduate 
laboratory.  You might want to direct the attention of the students to certain aspects of the set-up, 
possibly even to remind them what the parts are named, or where they are kept in the lab: 

 

9.4.1.1 Adding Text Captions 

From this section, you will find out how to add callouts to the vacuum distillation apparatus: 
1. First, let us set the font to be used for the text.  From the Tools menu, choose the Font Panel 

and Paragraph Panel commands. 
2. Specify the settings as follows, and then close the panels: 

 

3. On the Drawing toolbar, click Text , 
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4. Click to the left of the thermometer.  In the text box that appears type Thermometer. Sign out 
from instructor.  To narrow the text box, drag its right border: 

 
5. Click outside of the text box to leave the Text mode and to fix the caption. 

Tip To edit the text later, on the Editing toolbar, click Text  again, and click the text. 
6. Repeat steps 4 and 5 to add other captions. 

7. If necessary, right-click to quickly switch to the Select/Move/Resize  tool, and then move 
the captions to arrange them around the apparatus: 

 

9.4.1.2 Inserting Callouts 

Now we are going to include the captions into callouts. 

1. On the Drawing toolbar, click the right-bottom corner (i.e., the small white triangle) of the 

Callout  button to view the drop-down panel, and choose the square callout type: 

 
2. Point to the first text caption so the that callout outline appears around it, and click to fix the 

callout: 

 
3. Subsequently point to other captions (except for Water In / Water Out), and click to fix the 

callouts. 
4. Right-click in the workspace to leave the Callout mode. 
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9.4.1.3 Reshaping Callouts 

Now we are going to modify the callouts so that their pointing ends are directed at the required 
objects. 

1. On the Editing toolbar, click Edit Nodes . 
2. Select the first drawn callout by clicking it.  Note that the nodes appear on the callout: 

 
3. Drag the lowest node to a new location so that it correctly points to the object you want to 

annotate: 

 
Tip Dragging the corner nodes modifies the size of the callout. 

4. Without leaving the Edit Nodes mode, click other callouts and repeat step 2. 
5. As soon as all the callouts are redirected as necessary, right-click in the workspace to leave 

the Edit Nodes mode. 

6. Using the Draw Arrow  tool from the Drawing toolbar, add arrows to indicate the water 
inlets and outlets. 

7. Select both the arrows, and double-click to display the Objects Panel dialog box. 
8. Set the pen color to red, click Apply, and then close the panel. 

Note The CHAPTER9.SK2 file (Page 3/6) with the distillation apparatus can be found in 
the ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9. On the General toolbar, click New Page . 
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9.5 Drawing a Two-chain DNA Strand 

 This section is based on the DNA_CH.EXE movie which can be found in the 
\\MOVIES\CHEMSK folder. 

We are going to draw the following two-chain DNA Strand: 

 
1. On the General toolbar, in the Zoom box, set the zoom value back to 100%. 

2. On the Drawing toolbar, click Polyline . 
3. Drag vertically down from the starting point of the curve to extend the direction line. 
4. Release the mouse button. 
5. Move the mouse to the right and down (as shown in the scheme below) to draw the curve. 
6. Drag vertically down to extend the direction lines. 

Tip By changing the length of the direction lines you can modify the form of the curve. 
7. Release the mouse button, and right-click twice to finish drawing the curve and to activate the 

Select/Move/Resize  tool: 

 
8. Point to the selected curve and, while holding down CTRL+SHIFT, drag it down. 

Note Holding down CTRL while dragging leaves behind an instant copy of the object and 
holding down SHIFT forces the object to move strictly vertically or horizontally. 
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9. Select both curves either by dragging the selection rectangle around them or by clicking each 
of the curves while holding down SHIFT, and then, from the Object menu, choose Connect 
Lines to connect the right ends of the curves: 

 

10. On the Editing toolbar, click Edit Nodes , and proceed with the following to draw a 
segment: 

a. On the Node toolbar, click Connect Vertices  to connect the left terminal nodes with 
a line. 

b. Select the two right nodes by dragging the selection rectangle around them, and then, on 

the Node toolbar, click Convert to Line . 
c. Right-click to leave the Edit Nodes mode and to switch to the Select/Move/Resize tool 

: 

 
11. Make a copy of the obtained segment by dragging it with CTRL+SHIFT as described above in 

step 8. 

12. On the Editing toolbar, click Flip Left to Right  to flip the segment, and then click Send to 

Back  to send the segment to the background. 

 
Tip It may take some time to correctly position the segments by manually moving them.  

To align their position automatically, select both the segments, and apply the Center 
Horizontally tool  to the segments. 
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13. Select both the segments either by dragging the selection rectangle around them or by 
clicking while holding down SHIFT, and make a copy (holding down CTRL+SHIFT while 
dragging).  Correct the position if necessary: 

 
14. Select the segments marked with bullets in the scheme below by clicking them while holding 

down SHIFT. 
15. Double-click any of the segments to open the Objects panel: 

 
16. On the Fill tab, specify the above settings, and then click Apply: 
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17. Select the other two segments (marked with crosses in the scheme below), and specify the 
following settings on the Objects panel: 

 
18. Click Apply to obtain the following spiral picture: 

 
19. Close the Object Panel dialog box. 
20. Select the whole spiral by dragging the selection rectangle so that it includes all the spiral 

segments, and make a copy of it by dragging while holding down CTRL+SHIFT. 

21. On the Editing toolbar. click Flip Left to Right  , and then click Flip Top to Bottom : 
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22. Select the segments marked with bullets in the picture below by clicking while holding down 

SHIFT, and then click Send to Back : 

 
23. Select all of the segments, and group them. 

Note The CHAPTER9.SK2 file (Page 4/6) with the two-chain DNA strand can be found in 
the ACD/Labs example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

24. On the General toolbar, click New Page . 

9.6 Drawing Lipids and Micelles 

This section explains how to create the pictures of lipid and micelle. 

9.6.1 Drawing a Lipid 

 
1. On the Drawing toolbar, click Ellipse . 
2. Drag in the workspace while holding down SHIFT to draw a circle. 
3. Click the black color of the Color palette to fill the circle—this will be a phospholipid body: 

 

4. On the Drawing toolbar, click Polyline . 
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5. Click repeatedly in the workspace to draw the carbonic tail, and then right-click to finish 
drawing: 

 
Tip To easily draw the symmetric zigzag line, you may previously select the Snap on 

Grid and/or Show Grid from the Options menu. 

6. With the zigzag line selected, click Edit Nodes  and smooth the line in the following way: 
a. Select all the nodes of the drawn line by dragging the selection rectangle around it.  Note 

that selected nodes become black. 

b. On the Node toolbar, click Convert to Curve , and then click Smooth . 

c. Right-click to switch to the Select/Move/Resize  tool. 

 
7. Point to the curve and drag it right while holding down CTRL+SHIFT to leave the copy of the 

curve behind. 
8. Select both of the curves, and then arrange them as tails as shown at the beginning of the 

section by dragging them to the phospholipid body. 

9. Select, and then group elements of the phospholipid by clicking Group  on the Editing 
toolbar. 
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9.6.2 Drawing a Micelle 

Following the general scheme given below, draw the phospholipid micelle using the copying 

feature (hold down CTRL+SHIFT while dragging), Group , Rotate 90° , and 

Select/Move/Rotate  tools, as well as the aligning and flipping tools: 

 
Note The CHAPTER9.SK2 file (Page 5/6) with the micelle can be found in the ACD/Labs 

example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 

9.7 Creating Tables 

Starting from version 7.0, ACD/ChemSketch offers an enhanced tool for drawing and managing 
tables.  In this section, you will learn how to insert the table, add data to the table, and edit the 
table. 

As an example we will draw the following table: 

 

9.7.1 Drawing Table Contents 

First of all, we should draw the contents for our table: 

1. On the General toolbar, click New Page . 
2. Switch to the Structure mode. 
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3. Draw the structures of benzene, naphthalene, and quinoline using the technique described in 
the previous sections: 

Tip  You can also find these structures using the Dictionary  tool of the References 
toolbar. 

N

 

4. Switch to the Draw mode, on the Drawing toolbar, click the white triangle on the Text  
button, choose the Artistic Text  tool from the drop-down panel that appears, and then 
input the names for each of the structures: 

N

Benzene Naphthalene Quinoline  

Tip You can also name these structures using the Generate Name for Structure  
button on the General toolbar. 

10. Now, return to the Structure mode, and calculate the Composition and Density properties for 
each of the compounds in the following way: 
a. On the Tools menu, point to Calculate, and then choose Select Properties to Calculate. 
b. In the Select Properties to Calculate dialog box that appears, click Unselect All 

. 
c. On the Properties list, select Composition and Density, and the click OK. 
d. Select the structure whose properties are to be calculated. 
e. On the Tools menu, point to Calculate, and then choose Selected Properties. 
f. In the Calculation Results dialog box that appears, click Copy To 

Editor  to paste the results as text to the workspace, and then move the 
text to an appropriate position. 

g. Switch back to the Structure mode. 
h. Repeat steps d–g for the rest of the structures. 

Note For more details on how to calculate properties individually, refer to Chapter  6. 
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5. Switch back to the Draw mode, and arrange the structures and text in the workspace for 
better viewing.  You should obtain something like the following: 

 

6. Choose the Artistic Text  tool, click the empty space, and type Structure.  Then click 
outside the text box. 

7. In the similar way input Name and Properties.  These are going to be the table headings: 

 
Note The current bold blue style of the caption text has been previously set in 

Section  9.4.1.1.  You will change it later, in Section  9.7.4. 

9.7.2 Inserting Table 

Now we can add the borders to the table contents: 

1. On the left toolbar, click Table  and drag in the empty workspace until you define the 
approximate size for your table. 

2. In the Insert Table dialog box that appears as you release the mouse button, set the number 
of rows and columns to 4 and 3 correspondingly: 

 
3. Click OK.  The empty table is inserted. 
4. Right-click to leave the Table drawing mode. 
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9.7.3 Placing Data into Table 

After the table is drawn, we can fill it in with the previously specified data: 

1. Make sure that the Select/Move/Resize  tool is enabled, and drag the Structure text to 
the upper leftmost cell of the table so that it is placed somewhere in the center of the cell.  As 
you release the mouse button the text is automatically added to the cell, and the cell is resized 
to fit the text (this is the first way to add the data to the table): 

  
2. Now drag the benzene structure to the cell right below the Structure heading.  Note that the 

cell size changes correspondingly: 

 
Tip If the last row of the table is not fully visible after the above operation, click the table to 

select it, and then drag down the lower anchor point of the Table object box. 
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3. Another way of filling in the table cell is as follows: click the naphthalene structure to select it, 
hold down SHIFT and click an empty cell below the cell with the benzene to select both 

objects.  On the Editing toolbar, click Group    The structure is automatically placed into 
the cell and the cell is fitted to the structure size: 

 
4. You can also add several objects to table at once: click the Benzene text, then hold down 

SHIFT and click the properties related to benzene to select both the objects. 

 
5. Drag them to place so that they are located over the two cells to the right of the benzene 

structure and release the mouse button.  The two objects are placed into separate cells: 

 
6. Add other objects to the cells either by dragging or selecting and grouping.  You should obtain 

something like the following: 

 
Tip If the text or any of the graphics are not fully visible, click the table to select it, and 

then drag the corresponding anchor point of the Table object box. 
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9.7.4 Modifying Table Contents 

Now we are going to modify the formatting of the table contents. 

1. Ensure that the Select/Move/Resize  tool is active, and drag over the upper row of cells 
to select them: 

 

2. On the Editing toolbar, click Group  to release it.  This will ungroup each of the cells and 
their contents.  You can see that now only the text is selected: 

 
3. Double-click any of the text elements to display the Objects Panel dialog box. 
4. On the Font tab, select the Bold check box, set the font size to 12 and color to black, and 

then click Apply: 

 
5. Close the dialog box. 
6. Click somewhere in the empty space to cancel selection of the elements. 
7. To place the text back into the table cell, select the text, hold down SHIFT, and select the cell 

where the selected text should be placed: 

 

8. Click Group .  The cell and contents are now grouped in a single object—you can see that 
when selecting the cell: 

 
9. Another way of grouping is to point to the text and drag it a little within the borders of the cell.  

As you release the button, the text will be automatically grouped with the cell. 

Tip To understand whether the object and the corresponding cell are grouped, point to 
the object: if the whole cell is surrounded with the selection frame, not the object only, 
the object has been inserted into the cell. 

10. Using any of the methods described, place all of the headings into the corresponding cells. 
11. Select all of the data cells of the Properties column, and double-click the selection to open 

the Objects Panel dialog box. 
12. Switch to the Cell tab, and then, in the Horizontal box, select Left to arrange the data along 

the left side of the column. 
13. Click Apply, and then close the dialog box. 
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9.7.5 Editing Table View 

Finally, we can modify the table view: 

1. Ensure that the Select/Move/Resize  tool is selected, and drag over the upper row to 
select it. 

2. Double-click the selection to display the Objects Panel dialog box. 
3. Click the right arrow  to display the Fill tab and then switch to the tab. 
4. Set the fill color to ivory: 

  
5. Click Apply:  The selected cells are filled with ivory color: 

  
6. Close the dialog box. 
7. Select the entire table, and double-click it to display the Objects Panel dialog box (note that 

the color is set to mixed on the Fill tab). 
8. Switch to the Pen tab, change the color to crimson, and click Apply. 
9. Close the dialog box. 
10. Click somewhere in the empty space to cancel selection of the table elements and view the 

results. 
11. Close the dialog box, save the file, and then close the document. 

Note The CHAPTER9.SK2 file (Page 6/6) with this table can be found in the ACD/Labs 
example folder, \\ACD\EXAMPLES\CHEMSK\. 
To switch to the required page, use the corresponding buttons on the Status bar. 
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10. Managing Documents 

If you have worked over the material described in the previous chapters, you should have several 
ACD/ChemSketch documents with various drawings.  In this chapter, we are going to practise 
some manipulations that concern the whole document. 

In this chapter, you will learn how to: 
• Insert headers and footers; 
• Convert the document to Adobe PDF format; and 
• Create a poster. 

Sections within this chapter do not pertain to some particular example and can be applied to any 
of your ACD/ChemSketch documents. 

10.1 Inserting Headers and Footers 

Starting from version 8.0, you can insert headers and footers for all of the pages in your 
document.  You only have to define the text or picture to be inserted in one page, and the rest of 
the pages will be provided with the same pattern. 
1. On the Pages menu, point to Header and Footer, and then choose Edit.  The header text 

box appears at the top of the page (to the left of the page’s header), along with the floating 
Header and Footer toolbar: 

  
2. Type the text to be a header o the page, for example, ACD/ChemSketch. 

3. On the Headers and Footers toolbar, click Go to Next Text . 
4. In the text box that appears at the center of the page’s header, type Author:. 

5. On the Header and Footer toolbar, click Insert AutoText , and choose 
Author.  Your login name template is automatically inserted. 

6. Click Go to Next Text  again to insert one more text box to the right of the page’s header. 

7. Click Insert AutoText , and choose Page X of Y to insert the corresponding 
text template. 

8. If you want to add data to the page footer, click Go to Next Text , and edit the footer in 
the aforementioned way. 

Note You can also insert any drawings to be present either in the header or footer.  
When in the Header and Footer Editing mode, draw or insert the picture using the 
ChemSketch tools, and place it to the required position.  As you leave this mode, 
the corresponding picture will be available in all the pages of your document. 
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9. As soon as the required data is inserted, leave the Header and Footer Editing mode by 
clicking Close  on the toolbar. 

10. Switch between the pages to view the headers and footers inserted. 

10.2 Converting to Adobe PDF 

ACD/ChemSketch includes a tool for converting ACD/ChemSketch files (.SK2) to the Adobe PDF 
format.  As soon as you have drawn some graphical objects as described in the previous 
chapters, you can convert your document to the Adobe PDF format. 

Note To be able to export file to PDF from ACD/ChemSketch, you do not have to install 
Adobe Acrobat or Adobe Reader on your computer, but to view PDF files, you 
should have any of them.  You can install Adobe Reader when running 
ACD/ChemSketch setup program, or download Adobe Reader from 
http://www.adobe.com. 

1. Make sure that the objects and structures are arranged on the screen in the way you want to 
see them in the PDF file. 

Tip Click Full Page  on the General toolbar to view the whole page. 

2. On the General toolbar, click Export to PDF . 
3. In the Export dialog box that appears, specify the name and location of your .PDF file, e.g. 

Chapter10.pdf, and click Save. 
4. As soon as the conversion is completed, browse to the newly created file, and open it with 

Adobe Reader to view the results. 

Note Some objects inserted via the OLE server (Insert Object command from the Edit 
menu) may not be converted into PDF.  In this case, a message box appears 
informing you of this. 

10.3 Creating a Multi-Page Poster 

Using ACD/ChemSketch, you can quickly draw a poster and print it on paper of any format.  
ACD/ChemSketch will automatically separate the poster into pages; the only thing you have to do 
(besides design) is to join them. 

 This section is based on the POSTER.EXE movie which can be found in the 
\\MOVIES\CHEMSK\ folder. 

1. From the File menu, choose Page Setup. 
2. On the Size & Orient. tab, set the size of an individual page (i.e., the format of paper sheets 

used by your printer) and choose the Landscape option. 
3. Switch to the Margins tab, and set the page margins. 
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4. Switch to the Poster tab.  Set the number of standard pages you want your poster to consist 
of.  You can see the automatically calculated size of the poster in the Virtual Page Size area: 

 
5. Click OK. 
6. Create your poster using the tools of the Structure and Draw modes. 

7. Click Full Page  to see the general layout and arrange the poster elements as you 
prepare it. 

Note You can use the Paste and Paste Special commands from the Edit menu to insert 
objects (text, pictures, etc.) created in other Windows applications.  You can also 
edit these objects using OLE.  To do this, select the object choose Edit <Object 
Type> Object command from the Edit menu. 

8. If you want to see how your poster will be divided into individual pages while being printed, 
from the Options menu, choose Preferences, and then, on the General tab of the 
Preferences dialog box that appears, under Borders, select the Printable Area check box. 

9. From the File menu, choose Print.  In the dialog box that appears, click Print to print your 
poster, and then join the pages. 

Tip You can also click Print  on the General toolbar. 
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11. Working with Styles in Structure Mode 

11.1 Objectives 

If you often display your structure with a particular set of attributes, such as size of font, style of 
font, thickness of bond line, etc., you can make ACD/ChemSketch remember these settings by 
saving them altogether as a Style.  This is especially helpful if you want to display structures one 
way when working with them, but make them conform to a particular journal style when 
submitting a paper for publication. 

In this chapter, you will learn how to: 
• Change the style of structures; 
• Save your style; 
• Apply an existing style; and 
• Set a default style. 

11.2 Changing Style of Structures 

A style is a collection of attributes for display (atom and bond for structures; pen, arrow, fill, font, 
paragraph for graphical objects and text) to which you can assign a name and save. 

First of all, draw the following structure in the Structure mode of the program: 
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This structure can be drawn with the help of the Template Window dialog box (DNA/RNA Kit 
tab) from the 2-deoxyriboso-5-phosphate, uracil, and guanine components.  For more details on 
how to draw structures using Template Window, refer to Section  5.5. 
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Note The CHAPTER11.SK2 file with this structure can be found in the ACD/Labs 
example folder, \\ACD\EXAMPLES\CHEMSK\. 

11.2.1 Applying a Journal Style 

Let’s say that you have written a scientific article and, to accompany it, you want to submit the 
drawing of the above structure to the European Journal of Organic Chemistry: 

1. Select the structure using the Select/Move  tool. 

Tip You can also click near the structure for that. 
2. Point to one of the selection squares on the structure so that they turn from “ ” to “ ”, and 

double-click to display the Properties dialog box. 
3. In the Current Style box, select Eur. J. Org Chem. (2004): 

 
Note Not all journals have explicit instructions for structural drawings, and so they do not 

appear as a definite style listed in the Structure Properties dialog box.  For more 
information on how to prepare the drawings for such publications, refer to the 
following section. 

4. Click Apply , and you will see the display of the structure changes to reflect 
that journal’s style.  Click outside the structure to deselect it so you can see it more clearly: 
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Note The CHAPTER11.SK2 file with this structure can be found in the ACD/Labs 

example folder, \\ACD\EXAMPLES\CHEMSK\. 
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5. From the File menu, choose Save As and save your structure to the DNAFRAG.SK2 file. 
6. Select the whole structure again, in the Properties dialog box, from the Current Style list, 

select Normal, and click Apply .  The structure should appear as before. 

Tip You can also click Undo  button on the General toolbar. 
7. Close the dialog box. 

11.2.2 Preparing for Publication 

In addition to making your structural drawing conform to the guidelines of a particular journal, 
there are many other matters to arrange during manuscript preparation.  For this reason, 
Advanced Chemistry Development has included Instructions for Authors, a hyperlinked list of 
guidelines for over 80 journals.  For example: 

1. From the Help menu, choose Instructions for Authors. 
2. Find the Journal of Organic Chemistry in the list. 
3. Click the link to the corresponding Web site or follow the indicated pathname of the Adobe 

PDF file to display the corresponding document with the Guidelines for Authors. 
4. On the Contents tab of the Help window, expand the Instructions for Authors heading to 

view to the list of available journals so you can view their guidelines too. 

11.3 Creating Your Own Style 

Let’s say that you want to make a presentation in which you want to colorfully distinguish 
between the sugar, phosphate, and amino acid groups of the portion of DNA you are describing. 

1. Open the file DNAFRAG.SK2 and ensure that you are in the Structure mode. 

2. Switch to the Lasso On tool  and click Select/Move . 
3. Select the sugar components while holding down SHIFT: 

 
4. Point to any part of the selected fragment so that the selection squares become black, and 

double-click to display the Properties dialog box. 
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11.3.1 User-Defined Style: Sugar 

Now we will define our own style for the sugar components: 
1. In the Atom Style and Bond Style areas, specify the color for the selected fragments (for 

example, red) and set the bond width to a different value (for example, 1.9 pt): 

 
Note Units of measurement used in most of the panels within ACD/ChemSketch 

correspond to those set in the Preferences dialog box (Options menu).  You may 
set values for width, length, etc. in points/inches/millimeters/centimeters.  Type the 
values and add the unit you want (pt/in/mm/cm), e.g., 5 pt.  The values will be 
recalculated in the corresponding units of measurement. 

2. Click Apply  and click outside the structure to cancel the selection.  As you 
can see, the selected segments are now colored with red: 
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3. To save this style for future use, in the Current Style box of the Properties dialog box, type 

Sugar, and click Save: 

  
4. In the Save Style panel that appears, click Yes. 
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11.3.2 User-Defined Style: Phosphate 

In this section, we will define our own style for the phosphate components: 

1. Similarly, select the phosphate parts of the structure, and define the same thick bond width 
and blue color for the bonds and atom fonts. 

2. Save this style as Phosphate, 

3. Click Apply  to apply the new style to the selected parts: 
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11.3.3 User-Defined Style: Base 

We can also define our own style for the bases: 

1. Select the base parts of the structure, and set the color of the atom symbols to dark green, the 
bonds to neon green, and define the same thick bond width. 

2. Save this style as Base. 

3. Click Apply  to apply the new style to the selected parts. 



Working with Styles in Structure Mode 

ACD/ChemSketch Tutorial 130 

4. Arrange all of the fragments that were shifted when changing their style.  The structure now 
should look like this: 
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11.3.4 User-Defined Style: Highlight 

Perhaps, during the course of your presentation you want to draw the attention of the audience to 
the oxygen atoms.  We will create a fourth style, Highlight, for this: 

1. Holding down SHIFT, click the oxygen atoms indicated below to select them: 

 
2. On the Properties dialog box, switch to the Atom tab. 
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3. Below the preview area, click the C and H buttons while holding down SHIFT to change the 
color and size of both the atom symbol (oxygen in this case) and hydrogen: 

   
Note You may also change other atom attributes (hydrogen index, charge, valence, 

isotope, numbering) by clicking the corresponding buttons. 
4. Change the color, atom size, and other attributes—for example, to the following settings: 

 
Tip You can also change the bond attributes in a similar manner. 

5. Click Apply  to obtain the following structure: 
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6. Save the style as Highlight. 
7. Close the Properties dialog box. 
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11.4 Applying Existing Styles 

To practice applying the styles you have just created, reopen the DNAFRAG.SK2 file. 

1. Use the Lasso tool  to select the furanose rings as shown in Section  11.3. 
2. From the Tools menu, choose Structure Properties. 
3. On the Properties dialog box that appears, from the Current Style box, choose Sugar: 

 
4. Click Apply .  The chosen style will be applied to the selected fragments. 
5. Choose the phosphate groups. 
6. From the Current Style box, choose Phosphate, and then apply the style to the selected 

fragments. 
7. Similarly, select the two bases in the DNA fragment, and apply the Base style to them. 

Tip The information about a user-defined style is stored on your local hard drive in the 
ACD/ChemSketch Private directory that is specified on the General tab of the 
Preferences dialog box, (to view the dialog box, on the Options menu, click 
Preferences), in a Style file called USERSTL.SK.  If you want to share your Style file 
with friends and colleagues, ask them to place a copy of your USERSTL.SK file into 
their Private directory. 

11.5 Setting a Default Style 

You can specify the style to be applied to your structure drawings by default (i.e., any structure 
drawn will be thereafter of that style) in one of the following ways: 

• From the Current Style box of the Properties dialog box, choose the required style (e.g., 
Normal), and click Set Default ; or 

• On the Options menu, point to Set Structure Drawing Style, and click the required style 
on the submenu to select it. 

Note To set the default style, you do not have to save your one.  You can just specify the 
required attributes on the panel tabs, and click Set Default . 
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12. Working with Styles in Draw Mode 

12.1 Objectives 

In the Draw mode, a style may include attributes of one or several objects: pen, fill, arrow, font, 
and paragraph.  This will allow you to create different styles for text, filled objects, arrows, and 
lines. 

In this chapter, you will learn how to: 
• Change an object’s style; 
• Save a style; and 
• Set a default style. 

12.2 Changing Style of an Object 

In Chapter  9 there was a brief introduction to changing an object’s style.  In this section, we will 
acquaint you with a general procedure: 

1. Switch to the Draw mode. 
2. Select the object (or objects) whose style you want to change. 
3. Double-click the selection to display the Objects Panel dialog box.  Depending on the kind of 

selected object(s) (shape, linear object, arrow, text, spectrum, table, and/or structure), Objects 
Panel may contain different Object mode buttons (Common, Shapes, Text, etc.): 
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4. Combine your choices from the tabs and their boxes to create your style, and click 
Apply  to apply changes. 

Note Settings from the Common mode (click the Common  button to turn this 
mode on) will be applied to all of the objects.  For example, changing the pen color 
to red will affect shapes, lines, and structures.  If you change any attribute in the 
Shapes  mode, it will affect shapes only. 

12.3 Saving Style 

The style you have created can be saved: 

1. To save the specified settings, on the Objects Panel dialog box, click Save As . 
2. In the Save User Style dialog box that appears, under Include Object’s Attributes, select 

the attribute that should be included in your style.  For example, if you want to create a special 
style for text, make sure that the Font Style and Paragraph Style check boxes are selected. 

3. In the Style Name box, type the name for your style, and click OK.  The style will be added to 
the list of styles.  It can be then loaded to Objects Panel and applied to the selected objects or 
set as the default. 

12.4 Applying Existing Style 

You can apply the saved style (either built-in or user-defined) to any selected object. 
1. Select the object(s) whose style you want to change. 
2. Double-click the selection to open the Objects Panel dialog box. 

3. Click Load , and then, from the drop-down list of styles, choose the required 
one.  The style attributes will be loaded into the panel. 

4. Click Apply . 

12.5 Setting Default Style 

The default style attributes can be specified on special Style panels that can be displayed using 
the corresponding commands from the Tools menu: 

• Pen Style Panel 
• Fill Style Panel 
• Arrow Style Panel 
• Font Panel 
• Paragraph Panel 
• Table Panel 

The style attributes specified on any of these panels immediately become the default. 
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You can load any existing style into any of these panels by clicking Load .  The 
style is automatically loaded into other Style panels, where it is applicable, and becomes the 
default. 

You can also load style attributes from the drawn object into any of the style panels: 

• Click Update From  (note that the mouse pointer changes to ), and then 
click the object.  The object’s style attributes are immediately loaded into every Style panel 
and are automatically set as the default. 

Note If you want to change the style of a specific drawn object without affecting the 
default one, use its own Objects Panel (see Section  12.2). 

12.6 Managing Styles 

To manage your styles (save, apply, rename, delete, or set as default), you can use the Style 
Panel dialog box: 

• From the Tools menu, choose Style Organizer Panel. 

 
In this dialog box, you can do the following: 

Desired Action Button to Click 

View the styles that contain a specific 
attribute (pen, arrows, fill, font, 
paragraph, table) 

Click the appropriate button at the top of the panel. 

View the whole list of styles Click the buttons at the top of the panel so that they all are 

selected: . 

Apply the style to the selected 
object(s) 

Select the needed style in the list, and click 
Apply . 

Set the style as default Select the needed style in the list, and click Set 
Default . 

Create a new style based on the 
current default settings Click New . 

Rename the style Select the needed style in the list, and click Rename .  
Note that the built-in styles (they appear in gray in the list) cannot 
be renamed. 
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Delete the style Select the style in the list, and click Delete .  Note that 
the built-in styles (appearing in gray in the list) cannot be deleted. 
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13. Creating Report Templates 

13.1 Objectives 

ACD/Report Template is a special tool that is used to create a template and generate standard 
reports on its basis instead of repeating the same editing procedure for each report.  Currently, 
you can do this in ACD/ChemSketch.  ACD/ChemSketch allows you to create report templates 
for data supported by 1D NMR, 2D NMR, Calc 2D NMR, MASS, UVIR, Curve, and Chrom 
modules of ACD/SpecManager, ChemFolder, ChromGenius, PhysChemHistory, 
PhysChemDatabase, AutoChrom.  Later, we are going to enlarge the list of programs which allow 
the creation of template-based reports.  With the Report Template tool, it is easy to meet your 
corporate standards. 

Using ACD/Report Template, you can, for example, arrange various ACD/SpecManager objects 
(such as tables, graphs, parameters, structures, and others) belonging to one or several 
spectra/curves/chromatograms on one or several pages. 

If you do not have any of the mentioned above modules, skip this chapter. 

In this chapter, you will learn how to: 
• Enter the Report Template mode; 
• Evaluate the information that will be inserted into the report, and decide which objects 

should be included; 
• Insert objects into the template; 
• Assign properties to each object; 
• Arrange the objects in an acceptable manner; and 
• Save the template to a separate file; and 
• Use the created templates. 

Note Prior to performing any of the procedures described below, ensure that you are in 
the Draw mode of ACD/ChemSketch. 

13.2 About Report Templates 

Each report template has its inherent set of template objects (or just objects) that can be 
common (text label, formatted text) or assigned to certain ACD/Labs program (e.g., spectrum, 
table, graph, chemical structure).  Each object has concrete set of properties which regulate its 
appearance.  For the most part, these properties are correlated with properties in the 
corresponding program.  If template objects have different identification numbers (ID), they refer 
to different ACD/SpecManager documents.  If there are no IDs assigned, all objects in this 
template refer to the same ACD/SpecManager document. 

It is possible to insert your company logo into template-based reports as a bitmap (for more 
information on how to insert a bitmap, refer to the corresponding topic in the Report Template 
Help located in the ACD/Labs installation directory, \\REPTEMPL.CHM). 
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Moreover, as soon as the template-based report is ready, you can easily insert all proper 
corrections using ACD/ChemSketch Objects panel which appears immediately by double-
clicking. 

13.3 Creating Template Objects 

There is a vast amount of information that you can insert into a report template.  To get the first 
insight into report templates, let's create an example. 

13.3.1 Inserting Spectrum Objects 

1. Switch to the Draw mode. 

2. On the Drawing toolbar, click Report Template .  Note that the information cursor  
appears. 

3. With the Report Template mode on, point to the top left corner of the workspace, and drag to 
define the size of the first template object: 

 
Note Do not worry too much about the size of the template box at this stage because 

you can change the size later. 
4. As soon as you release the mouse button, the ACD/ChemSketch Template dialog box 

appears.  The Template Type list contains names of all of the ACD/SpecManager modules 
that are installed on your computer, as well as the COMMON type (selected by default). 

Note Depending on the module’s name chosen from the Template Type list, the 
adjacent Objects list looks different: 
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When you choose a different template type in the list, the caption of the template 
object in the ChemSketch workspace changes correspondingly. 

We are going to create a template for 1DNMR and 2DNMR modules (however, if you do not have 
these modules of ACD/SpecManager, select other template types instead):. 
5. In the Template Type list, select 1D NMR, and then, in the Objects list, select Spectrum.  

Note that the object’s caption in the workspace changes to 1D NMR Spectrum. 
6. In the ID box, enter 1 to refer this object to a spectral document with the same ID.  Note that 

the object’s caption in the workspace becomes 1D NMR Spectrum (ID=1). 

Note For more information on how to assign IDs to ACD/SpecManager documents, refer 
to the corresponding How to create a template-based report topic of the Report 
Template Help located in the ACD/Labs installation directory, \\REPTEMPL.CHM.  
This Help is also a constituent of both ACD/ChemSketch Help and 
ACD/SpecManager Help. 

7. Click OK to close the ACD/ChemSketch Template dialog box.  Note that the Report 
Template mode is still active: 

 
8. Drag in the workspace to the right of the first object to draw a second template object 

approximately of the same size. 
9. In the Template Type list of the ACD/ChemSketch Template dialog box that appears, select 

2DNMR, and then, in the Objects list, select Spectrum. 

Thereby, we have allocated a spot for 2DNMR spectrum.  As this spectrum will be in another 
spectral document, we need to assign it a different ID: 
10. In the ID box, enter 2.  Keep the dialog box opened. 

Tip If you have only a single module of ACD/SpecManager on your PC, and therefore, 
only a single module name is available from the Template Type list of the 
ACD/ChemSketch Template dialog box, insert two instances of spectrum / 
chromatogram / curve (later on, spectrum) of the same type but assign different IDs to 
them.  When creating a report according to this template, you will be able to insert two 
different spectra, chromatograms, or curves. 
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13.3.2 Setting Display Preferences 

As the 2D spectrum object is created, you can set the display preferences for it at once: 

1. Click Settings  to display the 2D NMR Spectrum Template dialog box where 
you can set the display preferences for the 2D spectrum objects: 

 
Note Each template object has its inherent set of options included into a corresponding 

dialog box.  For more information on the options available in the dialog box for a 
given object, click Help. 

We are going to set the display preferences which are common for the majority of 
ACD/SpecManager modules: 
2. In the Spectrum Region area of the Spectrum tab, click Whole Spectrum.  In this case, the 

entire spectrum will be inserted into reports made according to this template. 

Note If you select Fixed or Current, only a specified region will be inserted. 
3. Switch to the Labels and Scales tabs, and change the settings for these elements as desired. 
4. Click OK to apply the changes. 
5. In the ACD/ChemSketch Template dialog box, click OK.  Note that the Report Template 

mode is still on and the second template object 2D NMR Spectrum (ID=2) remains selected 
(it has black nodes around it). 

ACD/ChemSketch Tutorial 140 



Creating Report Templates 

Now, let’s customize display preferences for the previously created template object of the 1D 
NMR spectrum: 
1. Double-click the 1D NMR spectrum object to make it active and to display the 

ACD/ChemSketch Template dialog box. 
2. Ensure that the Spectrum item is selected in the Objects list, and click 

Settings . 
3. In the ACD/1DNMR Spectrum Template dialog box that appears, click the Peaks tab: 

 
4. Specify the display of the peak labels: in the Position area, click Near Peak, and, under 

Orientation, click Vertical. 
5. In the Numeric Display area, enter 2.  In this case, two decimal places will be displayed in 

peak labels. 

Important If no peaks have been picked on a spectrum inserted into a future template-
based report, they will naturally not be visible on the spectrum.  This is also 
true for other options (integrals, multiplets, curves, etc.). 

6. Switch to the Spectrum tab. 
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7. In the Spectrum Region area, ensure that the X1, X2, Y1, and Y2 options are set to Full, 
and, in the Show area, select the Vertical Scale and Horizontal Scale check boxes: 

 
Note Although you do not see any immediate outcome when setting display preferences, 

the settings are stored by the program and placed into the corresponding template 
object. 

8. Look through the other tabs in your module-related dialog box to find out what other options 
are available, set other options if required (for more information on the options available, click 
Help), and then click OK to apply the changes. 

9. In the ACD/ChemSketch Template dialog box, click OK to close it. 

13.3.3 Inserting Structure and Spectrum Parameters Objects 

1. Select the Report Template tool again, and insert a Chemical Structure object of the 1D 
NMR template type with ID=1 (using the drawing instructions of Section  13.3.1). 
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2. In the ACD/ChemSketch Template dialog box, click Settings  to customize the 
display of the structure: 

 
3. In the Base Font area, set preferences for font style, size, and the color that will be used to 

draw the structure. 
4. Click the Bond Color box to display the color palette, and then select the color for bonds. 
5. Select the Show Atom Numbers check box, and then, under Number Font Style, set the 

proper font style for atom numbers. 
6. Close both the dialog boxes by clicking OK. 
7. Now, insert one more object of the 1DNMR type—Spectrum Parameters with ID=1. 
8. To customize the display of the spectrum parameters in reports, in the ACD/ChemSketch 

Template dialog box that appears, click Settings . 
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9. On the Fields tab of the ACD/Parameters Template dialog box that appears, choose the 
Select Fields option to select those spectrum parameters which you would like to appear in 
reports made according to this template and to tune in the display order of the selected 
parameters. 

10. Right-click in the list of parameters, and, from the shortcut menu that appears, choose 
Unselect All to clear all check boxes, and then select Comment, Date, File Name, and 
Solvent.  The selected fields will be inserted into the report: 

 

Note You can use the Move Up  and Move Down  buttons to 
rearrange the fields order in the list. 

11. Switch to the Styles tab. 
12. Select the Show Borders check box to show horizontal and vertical borders between each 

Name-Value pair. 
13. Select the Show Names check box to show the field names, otherwise only the values will be 

displayed. 
14. Select the One Column check box to show parameters in a column: one Name-Value pair 

under another. 
15. Click OK in both the dialog boxes. 
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13.3.4 Subscribing Template 

Now we are going to add a subscription to the template. 

1. Make sure that the Report Template  tool is on, and insert a long narrow box along the 
bottom border of the template page using the drawing instructions listed above. 

2. In the ACD/ChemSketch Template dialog box that appears, select COMMON in the 
Template Type list, and then, in the Objects list, select Formatted Text. 

3. Click Settings  to display the ACD/Formatted Text Template dialog box.  Using 
this dialog box, you can add any textual information to the template which will appear in any 
report made according to this template. 

4. In the text box, type a few words in the first text line to characterize the series of reports you 
are going to create on the basis of this template, for example, This Template is created for 
practice purposes. 

5. Press ENTER to start the next text line. 

6. Click the Insert  button to display the Select Field dialog box where you can 
specify the current date, time, or page number to be automatically inserted in the template 
page. 

7. In the Name list, select $Date, and then click OK. 
8. Select the text, and set the font and alignment preferences for it as desired using the tools 

available at the top of the dialog box: 

 
Note The Alignment buttons located in the upper right corner of the dialog box allow you 

to tune the horizontal  alignment of the text (over the left border, 
between the borders, and over the right border respectively), and the vertical 

 alignment (over the top border, between the borders, over the bottom 
border).  Border here denotes the template object’s border. 

9. Click OK in both the dialog boxes. 
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Now, your ChemSketch working area should look something like this: 

 
Note The CHAPTER13.SK2 file with this template can be found in the ACD/Labs 

example folder, \\ACD\EXAMPLES\CHEMSK\. 

13.4 Arranging Template Objects 

After all of the template objects have been inserted, it may be necessary to resize and rearrange 
them so that they fit properly. 

1. Switch to the Select/Move/Resize tool . 
2. Select the object you want to move or resize by clicking it. 
3. Using the following instructions, resize and rearrange the template objects to suit your 

requirements: 
a. Point to the inside of the template object making notice that the mouse pointer changes to 

.  Now, you can relocate the object by dragging it. 
b. Point to any node of the selected object box making notice that the mouse pointer changes 

to a double-headed arrow of the corresponding direction.  Now, you can resize the object 
by dragging it. 

Tip From the Options menu, choose select Snap on Grid and/or Show Grid to make 
your object-arranging work easier. 
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13.5 Saving Templates 

As soon as a template is ready, you need to save it into an *.SK2 file; otherwise, you will not be 
able to use it later: 

• From the File menu, choose Save As to display the Save Document As dialog box, and 
then specify the name and location for the ACD/ChemSketch file. 

13.6 Applying Templates 

As soon as ACD/ChemSketch is an integrated part of the most ACD/Labs software, you can 
immediately apply a template created within the ChemSketch window of an ACD/Labs application 
to report the desired data. 

In the following example, we will assume that ACD/SpecManager package with ACD/NMR 
WorkBook is installed and started on your computer, and the template-based report is created: 
1. Switch to the Processor window. 
2. From the View menu, choose ACD/NMR WorkBook to display the corresponding panel (if it 

is not displayed yet). 
3. On the toolbar of the empty ACD/NMR WorkBook panel, click Start Working With 

Project .  From now on, the toolbar contains two buttons allowing you either to 
create a new project or open an existing one. 

Note This step is required only when launching ACD/NMR WorkBook for the first time. 

4. Click Open . 
5. In the Open Project dialog box that appears, specify the ACD/SpecManager Project file 

located in the ACD/Labs example folder, 
\\EXAMPLES\SPECMAN\2DNMR\NMR_PROJ\STRYCH-TEST.SMP. 

6. Click Open to load the project to the Processor window. 
7. From the Edit menu, point to Create Report, and choose by Template. 
8. In the Select Report Template dialog box that appears, select the location and file name of 

the ACD/ChemSketch template you have previously created. 
9. Click OK. 
10. After the report is created, you are automatically transferred to the ChemSketch window. 

If necessary, you can further edit the report objects that are not correctly displayed: 
1. Go to the first page of the report, and double-click the Structure object to display the Objects 

Panel. 
2. On the Atom tab, set the symbol size to 10 and color to navy blue, and then click 

Apply . 

For further detail on creating template-based reports, see the User Guides on the corresponding 
modules of ACD/SpecManager or look through the corresponding SpecManager Help topics. 
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